Continuum
  1. Continuum
  2. CONTINUUM-401

cannot delete project (stuck on 'in progress')

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: 1.0.2
    • Component/s: None
    • Labels:
      None
    • Environment:
      running on linux debian
      trying to access from winXP
    • Complexity:
      Intermediate
    • Number of attachments :
      3

      Description

      one of my projects got stuck in the 'in progress' state and cannot be deleted from the web interface.
      it's been in this state for > 24 hrs so it seems permanent.

      attaching screenshot.

      let me know if i should attach a log (and which one)

      1. wrapper-2005-11-25.log
        76 kB
        Yann Le Du
      2. wrapper-2005-12-21.log
        103 kB
        Yann Le Du
      1. palulustuck.JPG
        43 kB

        Issue Links

          Activity

          Emmanuel Venisse added a comment -

          Can you look at logs if your continuum restart during the night. I can't reproduce a "In Progress" state if i don't restart continuum when it build some projects. In 1.0.2, all project with a state "In Progress" will be repair when continuum will be restart.

          Yann Le Du added a comment -

          Aah ! I didn't notice it in precedent tests (I'm quite sure it wasn't there), but Continuum indeed restarted twice last Friday, at 22:01 and 22:32, though I can't tell why (nobody was working at this time). The error is :
          ERROR | wrapper | 2005/11/25 22:32:48 | JVM appears hung: Timed out waiting for signal from JVM.
          ERROR | wrapper | 2005/11/25 22:32:48 | JVM did not exit on request, terminated
          Here is the log : wrapper-20051125.log

          Noticed CONTINUUM-478 and CONTINUUM-479, good idea, thanks !

          Yann Le Du added a comment -

          Restart of Continuum could be due to lack of memory. See what I got today : wrapper-2005-12-21.log
          I'm going to try and solve this by changing the Plexus JVM memory options in continuum/bin/linux/wrapper.conf

          Yann Le Du added a comment -

          Using these parameters in continuum/bin/linux/wrapper.conf solved the "out of memory error" for us :
          ...

          1. Initial Java Heap Size (in MB)
            wrapper.java.initmemory=64
          1. Maximum Java Heap Size (in MB)
            wrapper.java.maxmemory=256
            ...

          About the other cases of restart, it finally seems the cause was a concurrent backup process on our server...
          So, in conclusion, I'd say we have no more stability problem with 1.0.2. And if any, thanks to CONTINUUM-478, the projects aren't stuck.

          Emmanuel Venisse added a comment -

          Fixed by CONTINUUM-478


            People

            • Assignee:
              Emmanuel Venisse
              Reporter:
              Adam Kiezun
            • Votes:
              3 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: