Continuum
  1. Continuum
  2. CONTINUUM-2678

Error sending mails: cli to get mvn version return code 1

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: 1.3.7
    • Fix Version/s: None
    • Component/s: Notifier - Mail
    • Labels:
      None
    • Environment:
      Red Hat Enterprise Linux AS release 4 (Nahant Update 4)
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Any idea why I get this error sometimes

      2012-04-12 00:00:38,541 [pool-1-thread-15] ERROR org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher - Error while trying to use the mail notifier.
      org.apache.maven.continuum.notification.NotificationException: Error while generating mail contents.
      at org.apache.maven.continuum.notification.mail.MailContinuumNotifier.buildComplete(MailContinuumNotifier.java:409)
      at org.apache.maven.continuum.notification.mail.MailContinuumNotifier.buildComplete(MailContinuumNotifier.java:306)
      at org.apache.maven.continuum.notification.mail.MailContinuumNotifier.sendMessage(MailContinuumNotifier.java:280)
      at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.sendNotification(DefaultContinuumNotificationDispatcher.java:194)
      at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.sendNotification(DefaultContinuumNotificationDispatcher.java:149)
      at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.buildComplete(DefaultContinuumNotificationDispatcher.java:97)
      at org.apache.maven.continuum.buildcontroller.DefaultBuildController.endBuild(DefaultBuildController.java:230)
      at org.apache.maven.continuum.buildcontroller.DefaultBuildController.build(DefaultBuildController.java:187)
      at org.apache.maven.continuum.buildcontroller.BuildProjectTaskExecutor.executeTask(BuildProjectTaskExecutor.java:48)
      at org.apache.continuum.taskqueueexecutor.ParallelBuildsThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ParallelBuildsThreadedTaskQueueExecutor.java:120)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: org.apache.maven.continuum.installation.InstallationException: cli to get mvn version return code 1
      at org.apache.continuum.installation.DefaultInstallationService.getExecutorConfiguratorVersion(DefaultInstallationService.java:440)
      at org.apache.maven.continuum.notification.mail.MailContinuumNotifier.getBuilderVersion(MailContinuumNotifier.java:557)
      at org.apache.maven.continuum.notification.mail.MailContinuumNotifier.buildComplete(MailContinuumNotifier.java:382)
      ... 14 more

        Activity

        Brett Porter added a comment -

        this occurs when mvn is not in the path of Continuum. There is another issue to improve this handling.

        Brett Porter made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Brett Porter [ brettporter ]
        Resolution Not A Bug [ 6 ]

          People

          • Assignee:
            Brett Porter
            Reporter:
            Francisco Herrera
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: