Continuum
  1. Continuum
  2. CONTINUUM-2581

Unable to release with distributed builds enabled

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.0 (Beta)
    • Fix Version/s: 1.4.1
    • Component/s: XMLRPC Interface
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      1. NPE in rewrite-pom-phase
      2. Exception while doing a release perform even though it was successful.
      3. ClassCastException in getListener()

      2010-11-11 19:21:56,617 [btpool0-5] ERROR org.apache.xmlrpc.server.XmlRpcStreamServer - execute: Error while performing request
      org.apache.xmlrpc.XmlRpcException: Failed to invoke method getListener in class org.apache.maven.continuum.xmlrpc.server.ContinuumServiceImpl: [Ljava.lang.Object; cannot be cast to java.util.List
      at org.apache.maven.continuum.xmlrpc.server.ContinuumXmlRpcMetaDataHandler.invoke(ContinuumXmlRpcMetaDataHandler.java:163)
      at org.apache.maven.continuum.xmlrpc.server.ContinuumXmlRpcMetaDataHandler.execute(ContinuumXmlRpcMetaDataHandler.java:132)
      at org.apache.xmlrpc.server.XmlRpcServerWorker.execute(XmlRpcServerWorker.java:43)
      at org.apache.xmlrpc.server.XmlRpcServer.execute(XmlRpcServer.java:83)
      at org.apache.xmlrpc.server.XmlRpcStreamServer.execute(XmlRpcStreamServer.java:191)
      at org.apache.xmlrpc.webserver.XmlRpcServletServer.execute(XmlRpcServletServer.java:104)
      at org.apache.maven.continuum.xmlrpc.server.ContinuumXmlRpcServlet.doPost(ContinuumXmlRpcServlet.java:190)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:502)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157)
      at org.apache.struts2.dispatcher.ng.filter.StrutsExecuteFilter.doFilter(StrutsExecuteFilter.java:73)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1148)
      at com.opensymphony.sitemesh.webapp.SiteMeshFilter.obtainContent(SiteMeshFilter.java:129)
      at com.opensymphony.sitemesh.webapp.SiteMeshFilter.doFilter(SiteMeshFilter.java:77)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1148)
      at org.apache.struts2.dispatcher.ng.filter.StrutsPrepareFilter.doFilter(StrutsPrepareFilter.java:65)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1148)
      at org.springframework.web.filter.CharacterEncodingFilter.doFilterInternal(CharacterEncodingFilter.java:96)
      at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1148)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:387)
      at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
      at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
      at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:765)
      at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:417)
      at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:230)
      at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
      at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
      at org.mortbay.jetty.Server.handle(Server.java:326)
      at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:534)
      at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:879)
      at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:747)
      at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:218)
      at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)
      at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:409)
      at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:451)
      Caused by: java.lang.ClassCastException: [Ljava.lang.Object; cannot be cast to java.util.List
      at org.apache.maven.continuum.xmlrpc.server.ContinuumServiceImpl.processListenerMap(ContinuumServiceImpl.java:3028)
      at org.apache.maven.continuum.xmlrpc.server.ContinuumServiceImpl.getListener(ContinuumServiceImpl.java:2854)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.maven.continuum.xmlrpc.server.ContinuumXmlRpcMetaDataHandler.invoke(ContinuumXmlRpcMetaDataHandler.java:144)
      ... 36 more

        Activity

        Maria Catherine Tan added a comment -

        fixed in r1036488

        • fixed NPE during release prepare caused by empty scm tag
        • fixed ClassCastException when invoking getListener
        • fixed exception during release perform by only throwing the exception if the build agent is unreachable

          People

          • Assignee:
            Maria Catherine Tan
            Reporter:
            Maria Catherine Tan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: