Continuum
  1. Continuum
  2. CONTINUUM-2571

Error in changelog when preparing build with distributed build enabled

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.1
    • Component/s: Distributed Builds
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      2010-09-21 07:11:53,023 [pool-2-thread-1] INFO org.apache.continuum.buildagent.taskqueue.execution.PrepareBuildProjectsTaskExecutor - Performing action changelog-agent-project
      2010-09-21 07:11:53,024 [pool-2-thread-1] INFO action#changelog-agent-project - Getting changeLog of project: Maven Clean Plugin
      2010-09-21 07:11:53,084 [pool-2-thread-1] INFO scmManager - Executing: /bin/sh -c cd /Users/marica/Documents/projects/continuum-trunk/continuum-buildagent/continuum-buildagent-webapp/target/data/build-agent/working-directory/1 && svn --non-interactive log -v -r http://svn.apache.org/repos/asf/maven/plugins/trunk/maven-clean-plugin
      2010-09-21 07:11:53,085 [pool-2-thread-1] INFO scmManager - Working directory: /Users/marica/Documents/projects/continuum-trunk/continuum-buildagent/continuum-buildagent-webapp/target/data/build-agent/working-directory/1
      2010-09-21 07:11:53,220 [pool-2-thread-1] WARN action#changelog-agent-project - Error getting change log of project Maven Clean Plugin
      2010-09-21 07:11:53,221 [pool-2-thread-1] WARN action#changelog-agent-project - Command Output: svn: Syntax error in revision argument 'http://svn.apache.org/repos/asf/maven/plugins/trunk/maven-clean-plugin'

      2010-09-21 07:11:53,221 [pool-2-thread-1] WARN action#changelog-agent-project - Provider Message: The svn command failed.

        Activity

        Wendy Smoak added a comment -

        Can you explain what the problem is and how to reproduce it?

        Why do you think it's a problem with Continuum vs. the Changelog plugin itself?

        Maria Catherine Tan added a comment -

        To reproduce this:
        1. enable distributed builds
        2. build a project

        if you look at the logs you'll see that error there so it means the changelog is not working.

        Carlos Sanchez said that he already applied a patch to maven-scm-svnexe-provider and made it work so we need to track why this is happening in build agent?

        Maria Catherine Tan added a comment -

        Fixed in r1044989


          People

          • Assignee:
            Maria Catherine Tan
            Reporter:
            Maria Catherine Tan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: