Continuum
  1. Continuum
  2. CONTINUUM-2538

[Regression] Unable to release using provide parameters

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.1
    • Fix Version/s: 1.4.1
    • Component/s: Release
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      I'm getting NPE when trying to do a release with provided parameters:

      2010-06-17 08:00:35,495 [Thread-9] ERROR taskQueueExecutor#perform-release - Error executing task
      edu.emory.mathcs.backport.java.util.concurrent.ExecutionException: java.lang.NullPointerException
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.getResult(FutureTask.java:299)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.get(FutureTask.java:118)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.waitForTask(ThreadedTaskQueueExecutor.java:159)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.run(ThreadedTaskQueueExecutor.java:127)
      Caused by: java.lang.NullPointerException
      at org.apache.maven.shared.release.util.ReleaseUtil.getRootProject(ReleaseUtil.java:59)
      at org.apache.maven.shared.release.phase.CheckoutProjectFromScm.execute(CheckoutProjectFromScm.java:109)
      at org.apache.maven.shared.release.DefaultReleaseManager.perform(DefaultReleaseManager.java:343)
      at org.apache.maven.shared.release.DefaultReleaseManager.performWithResult(DefaultReleaseManager.java:301)
      at org.apache.maven.continuum.release.executors.PerformReleaseTaskExecutor.execute(PerformReleaseTaskExecutor.java:111)
      at org.apache.maven.continuum.release.executors.AbstractReleaseTaskExecutor.executeTask(AbstractReleaseTaskExecutor.java:68)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987

      There was an additional changes in CheckoutProjectFromScm of maven-release-manager-2.0 that caused this:
      MavenProject rootProject = ReleaseUtil.getRootProject( reactorProjects );

      The reactorProjects is null when using provide paramters during release.

        Activity

        Brett Porter added a comment -

        Added a workaround so this works again, and ensured the selenium test passed


          People

          • Assignee:
            Brett Porter
            Reporter:
            Maria Catherine Tan
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: