Continuum
  1. Continuum
  2. CONTINUUM-2507

Error releasing project with POM encoded in UTF-8 with BOM

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.3.4 (Beta)
    • Fix Version/s: 1.4.1
    • Component/s: None
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      I have a Visual Studio project, when I do perform release in Continuum it results in: Release Error Unable to get release plugin parameters and process project - only whitespace content allowed before start tag and not \uef (position: START_DOCUMENT seen \uef... @1:1). The error doesn't indicate which file Continuum is having a problem processing. After some time spent investigating the files, I noticed the BOM character was in the POM causing the error in release. Additionally,I was able to successfully run 'mvn release:prepare -DdryRun=true -DautoVersionSubmodules=true' at the command line.

        Issue Links

          Activity

          Maria Catherine Tan added a comment -

          I tried running mvn release:prepare for a POM with BOM at the start of the text stream in the command line and I'm getting the same error. Running clean install didn't work as well and I'm using maven 2.2.1

          What maven version did you use?

          Can you also give a sample project for this. Thanks!

          Maria Catherine Tan added a comment -

          The problem is with the plexus XMLPullParser. It doesn't handle UTF-8 BOM at the start of the text.

          In MNG-2255, they suggested to use an external XMLPullParser instead of the plexus one.

          Maria Catherine Tan added a comment - - edited

          Instead of using the FileReader, I used the ReaderFactory of plexus util for creating an xml reader instance so that the encoding will be recognized.
          Committed in r946052 of trunk

          As for the problem with the BOM, I submitted a patch in MNG-4667 that will allow user to strip the BOM out of the POM, so you don't need to manually remove it.

          Brett Porter added a comment -

          already applied


            People

            • Assignee:
              Maria Catherine Tan
              Reporter:
              Leah Aliser
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: