Continuum
  1. Continuum
  2. CONTINUUM-2494

Unable to build a project even though the build agent is there.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.0 (Beta)
    • Component/s: None
    • Labels:
      None
    • Environment:
      1.4.0-SNAPSHOT rev. 928661
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Getting error "Unable to build projects because no build agent is configured" even though the build agent is there.

      Steps to reproduce.
      1. Add a buildagent.
      2. Create buildagent group with the newly created buildagent.
      3. Add a build environment and using the newly create buildagentGroup.
      4. Create project
      5. Set build definition of the project to use the build environment created in step 3.
      6. Build project.( successful build )
      7. Create a new buildagent
      8. Add a new buildagent group with the buildagent in step 7
      9. Add a new build environment using the buildagentgroup in step 8.
      10. Build the project created in step 4.

      Result : page displays "Unable to build projects because no build agent is configured"

      As I have checked after creating the first buildAGentGroup the changes were not displayed in continuum.xml. After adding a new buildagentGroup the continuum.xml has been updated but it only displays the first buildAgentGroup created.

        Issue Links

          Activity

          Wendy Smoak added a comment -

          Possibly related to CONTINUUM-2349 where that message was added?

          Gwen Harold Autencio added a comment -

          The message was added in project group summary page.
          It seems the build agent group was disabled after creating the second build agent group.

          Maria Catherine Tan added a comment -

          fixed in r929106.

          still need to create a unit test

          Maria Catherine Tan added a comment -

          added unit test r935791


            People

            • Assignee:
              Maria Catherine Tan
              Reporter:
              Gwen Harold Autencio
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: