Continuum
  1. Continuum
  2. CONTINUUM-2486

Error in backup output of builddefinition templates

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.6
    • Fix Version/s: 1.4.2
    • Component/s: XMLRPC Interface
    • Labels:
      None
    • Environment:
      Windows XP
    • Complexity:
      Intermediate
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      org.apache.maven.continuum.xmlrpc.backup.Backup produces output w/o <buildDefinitions> tags:

      <buildDefinitionTemplates>
      <buildDefinitionTemplates>
      <buildDefinition>
      .....
      </buildDefinition>
      </buildDefinitionTemplate>
      <buildDefinitionTemplates>

      instead of

      <buildDefinitionTemplates>
      <buildDefinitionTemplates>
      <buildDefinitions>
      <buildDefinition>
      .....
      </buildDefinition>
      </buildDefinitions>
      </buildDefinitionTemplate>
      <buildDefinitionTemplates>

        Activity

        Wendy Smoak added a comment -

        Is <buildDefinitionTemplates> really duplicated in the file or is that a typo?

        It looks wrong, but what problem does this cause and how do I reproduce it? (Have you perhaps tried to import the backup file and gotten an error?)

        Bob Verbrugge added a comment -

        Sorry, <buildDefinitionTemplates> is not duplicated, that's a typo. What is wrong is that the <buildDefinitions> tag is not generated and you then indeed get an error when importing the file. As far as I can see the bug is introduced in file Backup.java function backupAllBuildDefinitionTemplates(), here are

        startTag( "buildDefinitions", true );

        and

        endTag( "buildDefinitions", true );

        missing.

        Brett Porter added a comment -

        would you like to try adding a test and creating a patch for this since you've already done the narrowing down?

        Brett Porter added a comment -

        patch to review

        Brett Porter added a comment -

        applied


          People

          • Assignee:
            Brett Porter
            Reporter:
            Bob Verbrugge
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: