Continuum
  1. Continuum
  2. CONTINUUM-2452

project builds longer with distributed build enabled

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.4 (Beta)
    • Fix Version/s: 1.3.6
    • Component/s: Distributed Builds
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      I noticed that when distributed build is enabled, my builds take longer than usual.

        Activity

        Maria Odea Ching added a comment -

        I made some comparisons against building a large project using the distributed builds and regular builds. Below are the data I've gathered:

        Distributed builds (with build agent installed in the same machine as the master):
        1. using DB - 24 min 16 sec (build fresh); 12 min 40 sec
        2. using LDAP - 33 min 1 sec (build fresh)

        Regular builds:
        1. using DB - 23 min 35 sec (build fresh); 12 min 52 sec
        2. using LDAP - 36 min 6 sec (build fresh)

        I observed that the varying time of duration of the builds are caused mainly by the time it takes to checkout the project (when Build Fresh is enabled) and not necessarily by the build time. If you notice in the data above, the build duration time when it is not a fresh checkout are almost the same.

        Using LDAP also makes the build slower because of the remote lookups for the authorization and permission.

        Maria Catherine Tan added a comment -

        There's an added process during checkout/update of a project with distributed builds that tries to get the latest update date from the change log because sometimes the date in the changefile is 0.

        Maybe this is the cause.

        Maria Catherine Tan added a comment -

        Document that builds take longer with distributed builds.

        r907940 of 1.3.x branch
        r907942 of trunk

        Maria Catherine Tan added a comment -

        I resolved this issue since there's a documentation already.

        Please reopen this if you think it should be fixed :-D


          People

          • Assignee:
            Maria Catherine Tan
            Reporter:
            Maria Catherine Tan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: