Continuum
  1. Continuum
  2. CONTINUUM-2440

Unable to download html file from working copy

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.3.4 (Beta)
    • Fix Version/s: 1.4.0 (Beta)
    • Component/s: None
    • Labels:
      None
    • Environment:
      IE 6
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      Clicking on the html report file listed in the working copy results in an error page:

      Error message:

      The XML page cannot be displayed
      Cannot view XML input using style sheet. Please correct the error and then click the Refresh button, or try again later.

      The system cannot locate the resource specified. Error processing resource 'http://www...

      Users need to be able to download this file, (but the file does not need to be displayed within Continuum.)

      To reproduce, place html report file in the numbered working copy directory of any project, then view the working copy through Continuum and try to download the file.

        Issue Links

          Activity

          Wendy Smoak added a comment -

          What Continuum version is this being reported against? What is the html report file you mention?

          Caroline Jandayan added a comment -

          This is reported against Continuum 1.3.4 version.
          Attached is the report file mentioned above.

          Jevica Arianne B. Zurbano added a comment -

          I have tried replicating the issue using IE 6/7/8, Firefox 3 and Opera 10.

          I did not encounter the error mentioned above.

          In addition, I wasn't able to download the file and also encountered the following in the logs when clicking/downloading the html file (at least 100kb) using IE.

          WARN: /continuum/workingCopy.action: org.mortbay.jetty.EofException

          Jevica Arianne B. Zurbano added a comment -

          Fixed in r904431 of trunk.

          Wendy Smoak added a comment -

          Jevica, I don't understand whether you were able to reproduce the problem (you said you didn't encounter the error, but also that you couldn't download the file.) What did you fix then, and how? What do I look for to test it?

          It would be good to have more information in the commit log on r904431 so people can understand what the problem was and how your change fixed it.

          What about tests or documentation?

          Jevica Arianne B. Zurbano added a comment -

          Modification in r904431:

          • set content disposition ("attachment;") to be able to download files more than 100mb in size esp. in IE

          Wendy, I wasn't able to reproduce the error message:

          The XML page cannot be displayed
          
          Cannot view XML input using style sheet.
          Please correct the error and then click the Refresh button, or try again later.
          
          The system cannot locate the resource specified. Error processing resource 'http://www...
          

          In addition to that, I noticed using IE, I can view the files with <100mb in size.
          But I wasn't able to download the files more than 100mb; nothing happens when clicking/downloading the file. This is where the fix applies – telling the browser to download the file rather than to open it.

          Wendy Smoak added a comment - - edited

          How does the fix work?

          The only change I saw was:

          -        <param name="contentDisposition">filename="${downloadFilename}"</param>
          +        <param name="contentDisposition">attachment; filename="${downloadFilename}"</param>
          

          I also noticed that small html files display while larger ones download. I don't see anything in the commit diff about the size... is that set somewhere else, or just part of the webapp framework?

          (If you did some research on this, can you share the links to whatever you found? Or did you just know?)

          Jevica Arianne B. Zurbano added a comment -

          I'd like to make a correction, the download size is 100KB and not 100MB. Sorry for the confusion.

          The download size is already set in http://svn.apache.org/repos/asf/continuum/trunk/continuum-webapp/src/main/java/org/apache/maven/continuum/web/action/WorkingCopyAction.java (snippet below)

          if ( ( mimeType.indexOf( "image" ) >= 0 ) || ( mimeType.indexOf( "java-archive" ) >= 0 ) ||
               ( mimeType.indexOf( "java-class" ) >= 0 ) || ( downloadFile.length() > 100000 ) )
          {
              return "stream";
          }
          
          Dennis Lundberg added a comment -

          I have merged the documentation enhancements in r905173 from trunk to 'continuum-1.3.x' branch.


            People

            • Assignee:
              Jevica Arianne B. Zurbano
              Reporter:
              Caroline Jandayan
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: