Continuum
  1. Continuum
  2. CONTINUUM-2346

NPE in log on forced build and project never builds

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.3 (Beta)
    • Fix Version/s: 1.4.1
    • Component/s: None
    • Labels:
      None
    • Complexity:
      Intermediate
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      Project never build and getting NPE in logs.

      As I checked on the db, the NPE was caused by null values of the build definition of the project.

      2009-08-25 19:57:15,266 [pool-7-thread-1] INFO org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor - Performing action create-build-project-task
      2009-08-25 19:57:15,328 [pool-7-thread-1] ERROR org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor -
      java.lang.NullPointerException
      at org.apache.continuum.buildmanager.ParallelBuildsManager.buildProjects(ParallelBuildsManager.java:193)
      at org.apache.maven.continuum.core.action.CreateBuildProjectTaskAction.execute(CreateBuildProjectTaskAction.java:123)
      at org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor.buildProjects(PrepareBuildProjectsTaskExecutor.java:549)
      at org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor.executeTask(PrepareBuildProjectsTaskExecutor.java:177)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
      at java.lang.Thread.run(Thread.java:595)
      2009-08-25 19:57:15,329 [pool-7-thread-1] ERROR taskQueueExecutor#prepare-build-project - Error executing task
      org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Error executing action 'build-project'
      at org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor.buildProjects(PrepareBuildProjectsTaskExecutor.java:559)
      at org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor.executeTask(PrepareBuildProjectsTaskExecutor.java:177)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: java.lang.NullPointerException
      at org.apache.continuum.buildmanager.ParallelBuildsManager.buildProjects(ParallelBuildsManager.java:193)
      at org.apache.maven.continuum.core.action.CreateBuildProjectTaskAction.execute(CreateBuildProjectTaskAction.java:123)
      at org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor.buildProjects(PrepareBuildProjectsTaskExecutor.java:549)
      ... 7 more

        Activity

        Gwen Harold Autencio added a comment -

        The patch improves error description so that an informative message can be displayed to the user.
        Thanks.

        Marecor M. Baclay added a comment -

        Patch applied to r.1140475

        I modified a bit of the error message also. Thanks Gwen!


          People

          • Assignee:
            Marecor M. Baclay
            Reporter:
            Gwen Harold Autencio
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: