Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 1.2.3.1
    • Fix Version/s: 1.3.6
    • Component/s: Data Management
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      executing
      java -Xmx512m -jar data-management-cli-1.2.3.1-app.jar -buildsJdbcUrl jdbc:derby:continuum/database/continuum -usersJdbcUrl jdbc:derby:continuum/database/users -mode EXPORT -overwrite

      I get
      ...
      13956 [main] INFO JPOX.RDBMS - Validated 1 unique key(s) for table PROJECTNOTIFIER_CONFIGURATION
      13962 [main] INFO JPOX.RDBMS - Validated 1 foreign key(s) for table PROJECTNOTIFIER_CONFIGURATION
      13968 [main] INFO JPOX.RDBMS - Validated 2 index(es) for table PROJECTNOTIFIER_CONFIGURATION
      13984 [main] INFO JPOX.RDBMS - Validated 1 unique key(s) for table PROJECT_NOTIFIERS
      13997 [main] INFO JPOX.RDBMS - Validated 2 foreign key(s) for table PROJECT_NOTIFIERS
      14007 [main] INFO JPOX.RDBMS - Validated 3 index(es) for table PROJECT_NOTIFIERS
      127522 [main] INFO JPOX.RDBMS.Schema - Managing Persistence of Class : org.apache.continuum.model.repository.AbstractPurgeConfiguration [Table : ABSTRACTPURGECONFIGURATION, InheritanceStrategy : new-table]
      127522 [main] INFO JPOX.RDBMS.Schema - Managing Persistence of Class : org.apache.continuum.model.repository.RepositoryPurgeConfiguration [Table : REPOSITORYPURGECONFIGURATION, InheritanceStrategy : new-table]
      127580 [main] INFO JPOX.RDBMS - Validated 2 unique key(s) for table REPOSITORYPURGECONFIGURATION
      127586 [main] INFO JPOX.RDBMS - Validated 2 foreign key(s) for table REPOSITORYPURGECONFIGURATION
      127589 [main] INFO JPOX.RDBMS - Validated 3 index(es) for table REPOSITORYPURGECONFIGURATION
      127593 [main] INFO JPOX.RDBMS - Validated 1 unique key(s) for table ABSTRACTPURGECONFIGURATION
      127597 [main] INFO JPOX.RDBMS - Validated 1 foreign key(s) for table ABSTRACTPURGECONFIGURATION
      127600 [main] INFO JPOX.RDBMS - Validated 2 index(es) for table ABSTRACTPURGECONFIGURATION
      127683 [main] INFO JPOX.RDBMS.Schema - Managing Persistence of Class : org.apache.continuum.model.repository.DirectoryPurgeConfiguration [Table : DIRECTORYPURGECONFIGURATION, InheritanceStrategy : new-table]
      127732 [main] INFO JPOX.RDBMS - Validated 2 unique key(s) for table DIRECTORYPURGECONFIGURATION
      127736 [main] INFO JPOX.RDBMS - Validated 1 foreign key(s) for table DIRECTORYPURGECONFIGURATION
      127739 [main] INFO JPOX.RDBMS - Validated 2 index(es) for table DIRECTORYPURGECONFIGURATION
      130305 [main] INFO org.apache.maven.continuum.management.DataManagementCli - Processing Redback database...
      134987 [main] WARN JPOX.JDO - Property org.jpox.validateSchema unknown - will be ignored
      135249 [main] INFO JPOX.JDO - PersistenceManagerFactory - Vendor: JPOX Version: 1.1.6
      135250 [main] INFO JPOX.JDO - PersistenceManagerFactory initialised for datastore URL=jdbc:derby:continuum/database/users driver=org.apache.derby.jdbc.EmbeddedDriver userName=sa
      136463 [main] INFO JPOX.RDBMS - ================ DatabaseAdapter ==================
      136464 [main] INFO JPOX.RDBMS - Adapter : org.jpox.store.rdbms.adapter.DerbyAdapter
      136464 [main] INFO JPOX.RDBMS - Datastore : name="Apache Derby" version="10.1.3.1" (major=10, minor=1, revision=3)
      136464 [main] INFO JPOX.RDBMS - Driver : name="Apache Derby Embedded JDBC Driver" version="10.1.3.1" (major=10, minor=1)
      136464 [main] INFO JPOX.RDBMS - ===================================================
      136513 [main] INFO JPOX.RDBMS.Schema - Initialising Catalog "", Schema "SA" using "SchemaTable" auto-start option
      137205 [main] INFO JPOX.RDBMS.Schema - Catalog "", Schema "SA" initialised - managing 0 classes
      137230 [main] WARN JPOX.MetaData - No manager for annotations was found in the CLASSPATH so all annotations are ignored.
      Exception in thread "main" org.jpox.metadata.InvalidMetaDataException: Error in MetaData for field "localRepository" in class "ProjectGroup" : this is declared as org.apache.continuum.model.repository.LocalRepository with "persistence-modifier=none" yet has either "default-fetch-group=true" or "primary-key=true" specified! These should be false.
      at org.jpox.metadata.AbstractPropertyMetaData.populate(AbstractPropertyMetaData.java:820)
      at org.jpox.metadata.ClassMetaData.populatePropertyMetaData(ClassMetaData.java:434)
      at org.jpox.metadata.ClassMetaData.populate(ClassMetaData.java:251)
      at org.jpox.metadata.MetaDataManager.populateFileMetaData(MetaDataManager.java:1060)
      at org.jpox.metadata.JDOMetaDataManager.loadMetaDataForClass(JDOMetaDataManager.java:608)
      at org.jpox.metadata.JDOMetaDataManager.getMetaDataForClassInternal(JDOMetaDataManager.java:313)
      at org.jpox.metadata.MetaDataManager.getMetaDataForClass(MetaDataManager.java:377)
      at org.jpox.AbstractPersistenceManager.hasMetaDataForPersistenceCapableClass(AbstractPersistenceManager.java:4109)
      at org.jpox.AbstractPersistenceManager.assertPersistenceCapableClass(AbstractPersistenceManager.java:4139)
      at org.jpox.AbstractPersistenceManager.getExtent(AbstractPersistenceManager.java:2323)
      at org.codehaus.plexus.jdo.PlexusJdoUtils.getAllObjectsDetached(PlexusJdoUtils.java:358)
      at org.codehaus.plexus.jdo.PlexusJdoUtils.getAllObjectsDetached(PlexusJdoUtils.java:346)
      at org.codehaus.plexus.jdo.PlexusJdoUtils.getAllObjectsDetached(PlexusJdoUtils.java:335)
      at org.codehaus.plexus.jdo.PlexusJdoUtils.getAllObjectsDetached(PlexusJdoUtils.java:330)
      at org.codehaus.plexus.redback.keys.jdo.JdoKeyManager.getAllKeys(JdoKeyManager.java:143)
      at org.codehaus.plexus.redback.management.JdoDataManagementTool.backupKeyDatabase(JdoDataManagementTool.java:112)
      at org.apache.maven.continuum.management.redback.JdoDataManagementTool.backupDatabase(JdoDataManagementTool.java:66)
      at org.apache.maven.continuum.management.DataManagementCli.processDatabase(DataManagementCli.java:265)
      at org.apache.maven.continuum.management.DataManagementCli.main(DataManagementCli.java:177)

      the build.xml export seems to be correct.

        Issue Links

          Activity

          Gwen Harold Autencio added a comment -

          I tested this using the latest release 1.3.5.
          I still wasn't able to reproduce the error of Luca.
          More information of your user database may help the investigation.

          Luca added a comment -

          how you tried to export db with 1.3.5?
          the tool data-management-cli-1.3.5-app.jar not exists

          if is useful I can post the derbydb zipped

          Maria Catherine Tan added a comment -

          The tool was not deployed but there were no changes with regards to the model and the tool itself.

          It will be helpful if we can have your sample data to test it against.

          Brett Porter added a comment -

          Luca, have you tried upgrading Continuum just by reusing the existing database, or do you need the tool for other reasons? This is the last issue blocking our GA release now.

          Luca added a comment -

          Sorry, I don't will block the release.
          We need the tool because we will migrate to mysql.

          Discussing with our security responsible I cannot post our users db.
          They are other inconsistences in our db (we cannot delete some projects or local repositories),so we decided to rebuild both db from scratch with the new release
          For the users we will use the ldap integration.

          Anyway thanks for you effort!


            People

            • Assignee:
              Unassigned
              Reporter:
              Luca
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: