Continuum
  1. Continuum
  2. CONTINUUM-2320

NPE encountered while checking if project is in build queue using distributed build

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.1 (Alpha)
    • Fix Version/s: 1.3.4 (Beta)
    • Component/s: Distributed Builds
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      org.apache.continuum.distributed.transport.master.MasterBuildAgentTransportClient

      • Prepare build finished.
        [pool-2-thread-1] INFO
        org.apache.continuum.buildagent.taskqueue.execution.PrepareBuildProjectsTaskExecutor
      • Performing action create-agent-build-project-task
        [pool-1-thread-1] INFO
        org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor
      • Initializing build
        [pool-2-thread-1] ERROR taskQueueExecutor#prepare-build-agent - Error
        executing task
        org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Error
        executing action 'create-agent-build-project-task'
        at
        org.apache.continuum.buildagent.taskqueue.execution.PrepareBuildProjectsTaskExecutor.performAction(PrepareBuildProjectsTaskExecutor.java:387)
        at
        org.apache.continuum.buildagent.taskqueue.execution.PrepareBuildProjectsTaskExecutor.buildProjects(PrepareBuildProjectsTaskExecutor.java:442)
        at
        org.apache.continuum.buildagent.taskqueue.execution.PrepareBuildProjectsTaskExecutor.executeTask(PrepareBuildProjectsTaskExecutor.java:149)
        at
        org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
        at
        edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
        at
        edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
        at
        edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
        at
        edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
        at java.lang.Thread.run(Thread.java:595)
        Caused by: java.lang.NullPointerException
        at
        org.apache.continuum.buildagent.taskqueue.manager.DefaultBuildAgentTaskQueueManager.isProjectInBuildQueue(DefaultBuildAgentTaskQueueManager.java:205)
        at
        org.apache.continuum.buildagent.action.CreateBuildProjectTaskAction.execute(CreateBuildProjectTaskAction.java:83)
        at
        org.apache.continuum.buildagent.taskqueue.execution.PrepareBuildProjectsTaskExecutor.performAction(PrepareBuildProjectsTaskExecutor.java:378)
        ... 8 more

        Activity

        Maria Catherine Tan added a comment -

        fixed in
        r802673 of 1.3.x branch
        r802674 of trunk


          People

          • Assignee:
            Maria Catherine Tan
            Reporter:
            Maria Catherine Tan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: