Continuum
  1. Continuum
  2. CONTINUUM-2317

Unable to build some projects in build agent

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.3 (Beta)
    • Fix Version/s: 1.3.4 (Beta)
    • Component/s: Distributed Builds
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      A build agent is installed and running on the same machine where the master is running. In my master Continuum server, I have a multi-module project in one project group (let's name this Project Group A). It has a selenium test module that is in a different profile which I added it in a separate group (let's call this Project Group B) in the master Continuum server. I configured both groups to use a specific build environment where the build agent is attached. Project Group A builds successfully on the build agent, but Project Group B does not.

      Below is the error that I saw from the build agent's logs when building Project Group B.

      I also noticed that the pom.xml keeps being deleted causing the second error in the log snippet below. I manually updated the working directory to restore the missing pom.xml, but it got deleted again when I tried to build the group.

      2009-08-05 14:05:32,304 [pool-1-thread-1] ERROR org.apache.continuum.buildagent.build.execution.maven.m2.DefaultBuildAgentMavenBuilderHelper  - Cannot build maven project from /home/deng/test/continuum/continuum-build-agent/working-directory/57/pom.xml (No bean named 'wagon#http' is defined).
      2009-08-05 14:05:32,304 [pool-1-thread-1] ERROR org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor  - Error getting maven project
      org.apache.continuum.buildagent.build.execution.ContinuumAgentBuildExecutorException: Unable to read the Maven project descriptor '/home/deng/test/continuum/continuum-build-agent/working-directory/57/pom.xml': No bean named 'wagon#http' is defined
      
      	at org.apache.continuum.buildagent.build.execution.maven.m2.MavenTwoBuildExecutor.getMavenProject(MavenTwoBuildExecutor.java:275)
      	at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.getMavenProject(BuildProjectTaskExecutor.java:515)
      	at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.shouldBuild(BuildProjectTaskExecutor.java:405)
      	at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.executeTask(BuildProjectTaskExecutor.java:117)
      	at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      	at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      	at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      	at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
      	at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
      	at java.lang.Thread.run(Thread.java:595)
      2009-08-05 14:05:32,491 [pool-1-thread-1] INFO  org.apache.continuum.distributed.transport.master.MasterBuildAgentTransportClient  - Checking if project should build
      2009-08-05 14:05:32,492 [pool-1-thread-1] INFO  org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor  - Starting build of Centrepoint Selenium Test Suite
      2009-08-05 14:05:32,506 [pool-1-thread-1] INFO  org.apache.continuum.distributed.transport.master.MasterBuildAgentTransportClient  - Return project currently building
      2009-08-05 14:05:32,506 [pool-1-thread-1] INFO  org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor  - Performing action update-project-from-agent-working-directory
      2009-08-05 14:05:32,506 [pool-1-thread-1] INFO  org.apache.continuum.buildagent.action.UpdateProjectFromWorkingDirectoryAction  - Updating project 'Centrepoint Selenium Test Suite' from checkout.
      2009-08-05 14:05:32,508 [pool-1-thread-1] ERROR org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor  - Error executing action update-project-from-agent-working-directory '
      org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Error executing action 'update-project-from-agent-working-directory'
      	at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.performAction(BuildProjectTaskExecutor.java:283)
      	at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.executeTask(BuildProjectTaskExecutor.java:129)
      	at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      	at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      	at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      	at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
      	at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
      	at java.lang.Thread.run(Thread.java:595)
      Caused by: org.apache.continuum.buildagent.build.execution.ContinuumAgentBuildExecutorException: Could not find Maven project descriptor.
      	at org.apache.continuum.buildagent.build.execution.maven.m2.MavenTwoBuildExecutor.updateProjectFromWorkingDirectory(MavenTwoBuildExecutor.java:241)
      	at org.apache.continuum.buildagent.action.UpdateProjectFromWorkingDirectoryAction.execute(UpdateProjectFromWorkingDirectoryAction.java:49)
      	at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.performAction(BuildProjectTaskExecutor.java:261)
      	... 7 more
      

        Activity

        Maria Odea Ching added a comment -

        After doing some investigation, it seems this error occurs only for projects whose parent is a SNAPSHOT version. We added all the wagon jars from Continuum master to the build agent's WEB-INF/lib and the build proceeded.

        Encountered a problem though if the <scm> is not configured in the module but instead it is configured at the parent..

        2009-08-10 12:17:10,483 [pool-1-thread-1] ERROR org.apache.continuum.buildagent.build.execution.maven.m2.DefaultBuildAgentMavenBuilderHelper  - Missing 'scm' element in the Centrepoint Selenium Test Suite POM.
        2009-08-10 12:17:10,488 [pool-1-thread-1] ERROR org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor  - Error getting maven project
        org.apache.continuum.buildagent.build.execution.ContinuumAgentBuildExecutorException: Unable to read the Maven project descriptor '/home/deng/test/continuum/continuum-build-agent/working-directory/57/pom.xml': Centrepoint Selenium Test Suite
        
        	at org.apache.continuum.buildagent.build.execution.maven.m2.MavenTwoBuildExecutor.getMavenProject(MavenTwoBuildExecutor.java:275)
        	at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.getMavenProject(BuildProjectTaskExecutor.java:515)
        	at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.shouldBuild(BuildProjectTaskExecutor.java:405)
        	at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.executeTask(BuildProjectTaskExecutor.java:117)
        	at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
        	at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
        	at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
        	at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
        	at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
        	at java.lang.Thread.run(Thread.java:595)
        2009-08-10 12:17:10,928 [pool-1-thread-1] INFO  org.apache.continuum.distributed.transport.master.MasterBuildAgentTransportClient  - Checking if project should build
        2009-08-10 12:17:10,928 [pool-1-thread-1] INFO  org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor  - Starting build of Centrepoint Selenium Test Suite
        2009-08-10 12:17:11,026 [pool-1-thread-1] INFO  org.apache.continuum.distributed.transport.master.MasterBuildAgentTransportClient  - Return project currently building
        2009-08-10 12:17:11,027 [pool-1-thread-1] INFO  org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor  - Performing action update-project-from-agent-working-directory
        2009-08-10 12:17:11,030 [pool-1-thread-1] INFO  org.apache.continuum.buildagent.action.UpdateProjectFromWorkingDirectoryAction  - Updating project 'Centrepoint Selenium Test Suite' from checkout.
        2009-08-10 12:17:11,842 [pool-1-thread-1] ERROR org.apache.continuum.buildagent.build.execution.maven.m2.DefaultBuildAgentMavenBuilderHelper  - Missing 'scm' element in the Centrepoint Selenium Test Suite POM.
        2009-08-10 12:17:11,871 [pool-1-thread-1] ERROR org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor  - Error executing action update-project-from-agent-working-directory '
        org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Error executing action 'update-project-from-agent-working-directory'
        	at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.performAction(BuildProjectTaskExecutor.java:283)
        	at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.executeTask(BuildProjectTaskExecutor.java:129)
        	at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
        	at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
        	at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
        	at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
        	at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
        	at java.lang.Thread.run(Thread.java:595)
        Caused by: org.apache.continuum.buildagent.build.execution.ContinuumAgentBuildExecutorException: Error while mapping metadata:Can't load the maven project. Verify that your scm url is correct and remove/readd the project.
        Centrepoint Selenium Test Suite
        
        	at org.apache.continuum.buildagent.build.execution.maven.m2.MavenTwoBuildExecutor.updateProjectFromWorkingDirectory(MavenTwoBuildExecutor.java:250)
        	at org.apache.continuum.buildagent.action.UpdateProjectFromWorkingDirectoryAction.execute(UpdateProjectFromWorkingDirectoryAction.java:49)
        	at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.performAction(BuildProjectTaskExecutor.java:261)
        	... 7 more
        

        It looks like the POMs weren't merged?

        Maria Odea Ching added a comment -

        Attaching test project. Please take note of <scm> and <distributionManagement> configuration, they might need to be customized.

        Maria Catherine Tan added a comment -

        Added wagon jars which fixes the original error filed.
        r802979 of 1.3.x branch
        r802982 of trunk

        I wasn't able to replicate the error encountered if the <scm> is not configured in the module and I made some minor modification on the attached project (rename "modules" to "simple-project-modules")

        Maria Odea Ching added a comment -

        I think I was just referencing an outdated version of the parent POM (with no <scm> configured). I wasn't able to reproduce this again.

        On a different note, I cannot proceed with the release without the <scm> configuration in the module itself. I got the following error during release prepare using distributed builds:

        2009-08-11 12:31:51,096 [Thread-17] ERROR taskQueueExecutor#prepare-release  - Error executing task
        edu.emory.mathcs.backport.java.util.concurrent.ExecutionException: java.lang.ArrayIndexOutOfBoundsException: 77
        	at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.getResult(FutureTask.java:299)
        	at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.get(FutureTask.java:118)
        	at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.waitForTask(ThreadedTaskQueueExecutor.java:159)
        	at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.run(ThreadedTaskQueueExecutor.java:127)
        Caused by: java.lang.ArrayIndexOutOfBoundsException: 77
        	at org.apache.maven.shared.release.phase.RewritePomsForReleasePhase.translateUrlPath(RewritePomsForReleasePhase.java:249)
        	at org.apache.maven.shared.release.phase.RewritePomsForReleasePhase.translateScm(RewritePomsForReleasePhase.java:124)
        	at org.apache.maven.shared.release.phase.RewritePomsForReleasePhase.transformScm(RewritePomsForReleasePhase.java:79)
        	at org.apache.maven.shared.release.phase.AbstractRewritePomsPhase.transformDocument(AbstractRewritePomsPhase.java:271)
        	at org.apache.maven.shared.release.phase.AbstractRewritePomsPhase.transformProject(AbstractRewritePomsPhase.java:180)
        	at org.apache.maven.shared.release.phase.AbstractRewritePomsPhase.transform(AbstractRewritePomsPhase.java:116)
        	at org.apache.maven.shared.release.phase.AbstractRewritePomsPhase.execute(AbstractRewritePomsPhase.java:99)
        	at org.apache.maven.shared.release.DefaultReleaseManager.prepare(DefaultReleaseManager.java:194)
        	at org.apache.maven.shared.release.DefaultReleaseManager.prepareWithResult(DefaultReleaseManager.java:107)
        	at org.apache.maven.continuum.release.executors.PrepareReleaseTaskExecutor.execute(PrepareReleaseTaskExecutor.java:44)
        	at org.apache.maven.continuum.release.executors.AbstractReleaseTaskExecutor.executeTask(AbstractReleaseTaskExecutor.java:68)
        	at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
        	at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
        	at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
        	at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
        	at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
        	at java.lang.Thread.run(Thread.java:595)
        

        After adding the <scm> configuration in my selenium test module, I was able to successfully proceed with release prepare. I'll file this as a separate issue.

        Maria Catherine Tan added a comment -

        Closing since the original issue is fixed.


          People

          • Assignee:
            Maria Catherine Tan
            Reporter:
            Maria Odea Ching
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: