Continuum
  1. Continuum
  2. CONTINUUM-2272

Able to add secured projects without credentials

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.3.4 (Beta)
    • Component/s: Core system
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      1. add a secured project without entering any credentials and do not click 'use scm credentials'
      2. click add button
      --> Will have an authorization error while trying to add the project

      3. Repeat steps above but this time with credentials
      --> Successfully added the project

      4. Repeat steps #1&2 but this time choose a different group (continuum does not allow adding the same project to the same group)
      --> Successfully added the project

      #4 should still show an authorization error instead of successfully adding the project.

        Issue Links

          Activity

          Wendy Smoak added a comment -

          I want to document the expected behavior for the various cases. It's not clear how the credentials you supply when adding a project are used later. (And [unrelated to this issue] I think it might be caching the credentials supplied during the release, which IMO it shouldn't.)

          Where is the disabled test you mentioned? Even if we can't automate it we can define the prerequisites and the steps to test it manually. I can work on that.

          Maria Catherine Tan added a comment -

          For this issue, I did not perform any build or release. Just try to add the same project without credentials.

          The disabled test is in AbstractContinuumProjectBuilderTest

          Wendy Smoak added a comment -

          Attaching work in progress - defining requirements for what Continuum does with the credentials you provide when you add a project. Because of the checkbox on the add project form, cached svn credentials also come into play.

          It's currently in a spreadsheet, so this is a pdf export. I want to get it into plain text, but I know working with a table in APT would be painful. Maybe xdoc will work better...

          Wendy Smoak added a comment -

          Added requirements doc in r787528. It should show up here shortly: http://continuum.apache.org/ref/1.4.0-SNAPSHOT/credentials.html

          Wendy Smoak added a comment -

          Thanks for the additional info, Marica! I updated user docs in r787534 to clarify that the credentials are stored in plain text in the database and reused later for scm checkout and update.


            People

            • Assignee:
              Maria Catherine Tan
              Reporter:
              Maria Catherine Tan
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: