Continuum
  1. Continuum
  2. CONTINUUM-2261

NPE in check working directory action

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.4 (Beta)
    • Fix Version/s: 1.3.4 (Beta)
    • Component/s: None
    • Labels:
      None
    • Environment:
      1.3.4-SNAPSHOT r781487 on vmbuild
    • Complexity:
      Intermediate
    • Number of attachments :
      2

      Description

      The Directory project group on vmbuild shows errors in four of the eight scm urls. See INFRA-2037.

      Example SCM result:
      http://vmbuild.apache.org/continuum/scmResult.action?projectScmRootId=63&projectGroupId=139

      SCM result
      Project Group Name: Directory
      SCM Root URL: scm:svn:http://svn.apache.org/repos/asf/directory/apacheds/trunk
      State: Error
      SCM Error

      Exception:
      org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Error executing action 'check-working-directory'
      at org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor.performAction(PrepareBuildProjectsTaskExecutor.java:427)
      at org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor.updateWorkingDirectory(PrepareBuildProjectsTaskExecutor.java:241)
      at org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor.executeTask(PrepareBuildProjectsTaskExecutor.java:148)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.NullPointerException
      at org.apache.maven.continuum.core.action.CheckWorkingDirectoryAction.execute(CheckWorkingDirectoryAction.java:66)
      at org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor.performAction(PrepareBuildProjectsTaskExecutor.java:418)
      ... 8 more

        Activity

        Wendy Smoak added a comment -

        Attaching a screen shot of the Directory project group and the scm result.

        Emmanuel Venisse added a comment -

        Fixed in r.787650


          People

          • Assignee:
            Emmanuel Venisse
            Reporter:
            Wendy Smoak
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: