Continuum
  1. Continuum
  2. CONTINUUM-2229

Update the status icon of the project when it is added in build-prepare-queue

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3.4 (Beta)
    • Component/s: Web - UI
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      When it is forced build, the status icon of the project doesn't change if there are other projects waiting to be processed in build-prepare-queue. Users get confused that nothing happened especially if the project that precedes it is very big (hence taking too long to finish). We can change the status icon of the project to "in queue" as an indicator that it is already inserted in build-prepare-queue.

      To reproduce:
      1. add a small project
      2. add a big project
      3. build the big project and then immediately build the small project.
      notice the status icons of the small project, it will only be updated once the big project has finished processing in the build-prepare stage.

        Issue Links

          Activity

          jan ancajas added a comment -

          attached patch. thanks

          Wendy Smoak added a comment -

          I think this is a step in the right direction.

          If the 'in queue' icon is displayed, then I expect to see the project listed on the 'Queues' page. (I also expect to be able to cancel it.)

          Those can be separate issues, I just wanted to raise the concern here as I don't think this is a complete fix for the "I clicked build but nothing is happening!" user perception problem.

          Maria Catherine Tan added a comment -

          Projects won't be added to build queue until it finishes the prepare build successfully.

          So changing it to "in queue" icon might be confusing to users because they won't see the projects in the queues page.

          Instead of changing the icon of each project to "in queue" when they're in the the build prepare queue, we could change the icon of the project scm root url to "in queue" icon?

          WDYT?

          Maria Catherine Tan added a comment -

          Also showing the prepare build queues in the Queues page will be a great help

          Wendy Smoak added a comment -

          Has any work been done on this? On vmbuild (r777534) I'm seeing it show the 'checkout' icon next the scm url when the project is in the prepare build queue.

          http://people.apache.org/~wsmoak/continuum/continuum-scm-url-showing-checkout-instead-of-queued.png

          Maria Catherine Tan added a comment -

          While it is currently prepare build, the icon next to the scm url will show a 'checkout' icon. But while it is still in the prepare build queue, no icon to indicate that it is already in queue.

          Maria Catherine Tan added a comment -

          We can include in the documentation that when that "in queue" icon is displayed, it means that the project is either in the prepare build queue or in the build queue.

          Maria Catherine Tan added a comment -

          Patch applied in
          r800168 of 1.3.x branch
          r800170 of trunk

          Thanks Jan!

          Maria Catherine Tan added a comment -

          Added documentation
          r 800172 of 1.3.x branch
          r 800173 of trunk


            People

            • Assignee:
              Maria Catherine Tan
              Reporter:
              jan ancajas
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: