Continuum
  1. Continuum
  2. CONTINUUM-2207

Missing value for key 'scmResult' if build group project

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.2 (Beta)
    • Fix Version/s: 1.3.5 (Beta)
    • Component/s: None
    • Labels:
      None
    • Environment:
      Maven 2.1.0-M1 /
      Continuum 1.3.2 : Standalone version, lanched using the wrapper mode "console".
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Hi,

      Here is steps to reproduce the issue :

      • I created a group "myGroup" linked to a local repository : "C:\myRepo"
      • I configured a build definition for this group : "-e -B -U -P<profile> clean install"
      • I added all my projects to this group by the pom URL
      • I built all the projects using the build all project button

      Symptoms are :

      • The first project of the build queue is correctly built
      • The others failed with the error : "Missing value for key 'scmResult'"
      • If I re-build the project manualy, it works ...

      No detail in the continuum.log file:

      2009-04-27 15:43:02,319 [pool-1-thread-15] INFO org.apache.maven.continuum.buildcontroller.DefaultBuildController - Starting build of MY_PROJECT
      2009-04-27 15:43:02,350 [pool-1-thread-15] INFO org.apache.maven.continuum.buildcontroller.DefaultBuildController - The project was never be built with the current build definition, building
      2009-04-27 15:43:02,350 [pool-1-thread-15] INFO org.apache.maven.continuum.buildcontroller.DefaultBuildController - Performing action update-project-from-working-directory
      2009-04-27 15:43:02,475 [pool-1-thread-15] INFO org.apache.maven.continuum.buildcontroller.DefaultBuildController - Performing action execute-builder
      2009-04-27 15:43:02,819 [pool-1-thread-15] INFO org.apache.maven.continuum.notification.mail.MailContinuumNotifier - Message Subject: '[continuum] BUILD ERROR: MyGroup - MY_PROJECT - MyBuildDefinition'.
      2009-04-27 15:43:02,819 [pool-1-thread-15] INFO org.apache.maven.continuum.notification.mail.MailContinuumNotifier - Sending message: From '"<me>".
      2009-04-27 15:43:02,819 [pool-1-thread-15] INFO org.apache.maven.continuum.notification.mail.MailContinuumNotifier - Recipient: To '<recipitients>'.

      Kind Regards,

      Regis.

        Activity

        Maria Catherine Tan added a comment -

        Hi Regis,

        Could you attach the build result when you have the error: "Missing value for key 'scmResult'"

        Thanks!

        regis added a comment -

        Sure !

        org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Error executing action 'execute-builder'
        at org.apache.maven.continuum.buildcontroller.DefaultBuildController.performAction(DefaultBuildController.java:426)
        at org.apache.maven.continuum.buildcontroller.DefaultBuildController.build(DefaultBuildController.java:162)
        at org.apache.maven.continuum.buildcontroller.BuildProjectTaskExecutor.executeTask(BuildProjectTaskExecutor.java:48)
        at org.apache.continuum.taskqueueexecutor.ParallelBuildsThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ParallelBuildsThreadedTaskQueueExecutor.java:120)
        at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
        at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:178)
        at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1061)
        at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:575)
        at java.lang.Thread.run(Unknown Source)
        Caused by: java.lang.RuntimeException: Missing value for key 'scmResult'.
        at org.apache.maven.continuum.core.action.AbstractContinuumAction.getObject(AbstractContinuumAction.java:294)
        at org.apache.maven.continuum.core.action.AbstractContinuumAction.getScmResult(AbstractContinuumAction.java:202)
        at org.apache.maven.continuum.core.action.ExecuteBuilderContinuumAction.execute(ExecuteBuilderContinuumAction.java:89)
        at org.apache.maven.continuum.buildcontroller.DefaultBuildController.performAction(DefaultBuildController.java:404)
        ... 8 more

        Regis.

        Giancarlo Rosso added a comment -

        Same problem here, with identical stacktrace.
        I noticed tha before the error there's a warning:
        [pool-1-thread-2] WARN org.apache.maven.continuum.execution.maven.m2.MavenTwoBuildExecutor - Could not find the executable 'mvn' in
        this path:
        Linux RHEL 5.3 64bit, jdk1.5.0_17, continuum 1.3.2 and maven 2.0.10.

        Wendy Smoak added a comment -

        Is this still a problem in 1.3.4 or later?

        regis added a comment -

        Yes the problem is still present in version 1.3.4 with same build result and same java stack trace.

        Maria Catherine Tan added a comment -

        I prevented setting a null scmResult which is the cause of this problem.

        Fixed in:
        r819456 of 1.3.x branch
        r819457 of trunk

        Sometimes updating a working directory returns a null scmResult, maybe we need to file this in maven-scm.


          People

          • Assignee:
            Maria Catherine Tan
            Reporter:
            regis
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: