Continuum
  1. Continuum
  2. CONTINUUM-2205

occasional NullPointerException on httpError page

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.2 (Beta)
    • Fix Version/s: 1.3.4 (Beta)
    • Component/s: Web - UI
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      12311960 [btpool0-6] WARN org.mortbay.log - EXCEPTION 
      org.apache.jasper.JasperException: Exception in JSP: /WEB-INF/jsp/error/httpError.jsp:25
      
      22: 
      23: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
      24: 
      25: <s:i18n name="localization.Continuum">
      26: <html>
      27: <head>
      28:   <title>
      
      
      Stacktrace:
              at org.apache.jasper.servlet.JspServletWrapper.handleJspException(JspServletWrapper.java:504)
              at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:393)
              at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
              at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
              at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
              at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:362)
              at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
              at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
              at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:729)
              at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
              at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:285)
              at org.mortbay.jetty.servlet.Dispatcher.error(Dispatcher.java:135)
              at org.mortbay.jetty.servlet.ErrorPageErrorHandler.handle(ErrorPageErrorHandler.java:121)
              at org.mortbay.jetty.Response.sendError(Response.java:274)
              at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:433)
              at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
              at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
              at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:729)
              at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
              at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:206)
              at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
              at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
              at org.mortbay.jetty.Server.handle(Server.java:324)
              at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
              at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:829)
              at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:513)
              at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
              at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
              at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
              at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:450)
      Caused by: java.lang.NullPointerException
              at org.apache.struts2.views.jsp.ComponentTagSupport.doStartTag(ComponentTagSupport.java:50)
              at org.apache.jsp.WEB_002dINF.jsp.error.httpError_jsp._jspx_meth_s_i18n_0(org.apache.jsp.WEB_002dINF.jsp.error.httpError_jsp:100)
              at org.apache.jsp.WEB_002dINF.jsp.error.httpError_jsp._jspService(org.apache.jsp.WEB_002dINF.jsp.error.httpError_jsp:77)
              at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      

        Activity

        Emmanuel Venisse added a comment -

        Fixed in r.778998.


          People

          • Assignee:
            Emmanuel Venisse
            Reporter:
            Brett Porter
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: