Continuum
  1. Continuum
  2. CONTINUUM-2204

Continuum occasionally failing with "too many open files" after upgrade

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.2 (Beta)
    • Fix Version/s: 1.3.4 (Beta)
    • Component/s: Core system
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      14496628 [btpool0-9 - Acceptor0 SelectChannelConnector@0.0.0.0:8080] WARN org.mortbay.log - EXCEPTION
      java.io.IOException: Too many open files

      Will need to connect to a running instance such as vmbuild after some time and assess what dead file handles there are, as well as confirm the initial limits were appropriate.

        Issue Links

          Activity

          Wendy Smoak added a comment -

          I'm seeing this on vmbuild which was just upgraded to r774495

          2009-05-13 14:12:23,036 [pool-1-thread-4] ERROR org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher  - Error while trying to use the mail notifier.
          org.apache.maven.continuum.notification.NotificationException: Error while generating mail contents.
          	at org.apache.maven.continuum.notification.mail.MailContinuumNotifier.buildComplete(MailContinuumNotifier.java:413)
          	at org.apache.maven.continuum.notification.mail.MailContinuumNotifier.buildComplete(MailContinuumNotifier.java:310)
          	at org.apache.maven.continuum.notification.mail.MailContinuumNotifier.sendMessage(MailContinuumNotifier.java:284)
          	at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.sendNotification(DefaultContinuumNotificationDispatcher.java:194)
          	at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.sendNotification(DefaultContinuumNotificationDispatcher.java:149)
          	at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.buildComplete(DefaultContinuumNotificationDispatcher.java:97)
          	at org.apache.maven.continuum.buildcontroller.DefaultBuildController.endBuild(DefaultBuildController.java:236)
          	at org.apache.maven.continuum.buildcontroller.DefaultBuildController.build(DefaultBuildController.java:193)
          	at org.apache.maven.continuum.buildcontroller.BuildProjectTaskExecutor.executeTask(BuildProjectTaskExecutor.java:48)
          	at org.apache.continuum.taskqueueexecutor.ParallelBuildsThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ParallelBuildsThreadedTaskQueueExecutor.java:120)
          	at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
          	at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
          	at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
          	at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
          	at java.lang.Thread.run(Thread.java:619)
          Caused by: org.apache.maven.continuum.installation.InstallationException: Error setting up environmental variables
          	at org.apache.continuum.installation.DefaultInstallationService.getJdkInformations(DefaultInstallationService.java:319)
          	at org.apache.maven.continuum.notification.mail.MailContinuumNotifier.getJavaHomeInformations(MailContinuumNotifier.java:518)
          	at org.apache.maven.continuum.notification.mail.MailContinuumNotifier.buildComplete(MailContinuumNotifier.java:384)
          	... 14 more
          Caused by: org.codehaus.plexus.util.cli.CommandLineException: Error setting up environmental variables
          	at org.codehaus.plexus.util.cli.Commandline.getEnvironmentVariables(Commandline.java:464)
          	at org.codehaus.plexus.util.cli.Commandline.execute(Commandline.java:626)
          	at org.codehaus.plexus.util.cli.CommandLineUtils.executeCommandLine(CommandLineUtils.java:118)
          	at org.codehaus.plexus.util.cli.CommandLineUtils.executeCommandLine(CommandLineUtils.java:93)
          	at org.apache.continuum.installation.DefaultInstallationService.getJavaHomeInformations(DefaultInstallationService.java:339)
          	at org.apache.continuum.installation.DefaultInstallationService.getJdkInformations(DefaultInstallationService.java:315)
          	... 16 more
          Caused by: java.io.IOException: Cannot run program "env": java.io.IOException: error=24, Too many open files
          	at java.lang.ProcessBuilder.start(ProcessBuilder.java:459)
          	at java.lang.Runtime.exec(Runtime.java:593)
          	at java.lang.Runtime.exec(Runtime.java:431)
          	at java.lang.Runtime.exec(Runtime.java:328)
          	at org.codehaus.plexus.util.cli.CommandLineUtils.getSystemEnvVars(CommandLineUtils.java:251)
          	at org.codehaus.plexus.util.cli.CommandLineUtils.getSystemEnvVars(CommandLineUtils.java:217)
          	at org.codehaus.plexus.util.cli.Commandline.addSystemEnvironment(Commandline.java:440)
          	at org.codehaus.plexus.util.cli.Commandline.getEnvironmentVariables(Commandline.java:460)
          	... 21 more
          Caused by: java.io.IOException: java.io.IOException: error=24, Too many open files
          	at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
          	at java.lang.ProcessImpl.start(ProcessImpl.java:65)
          	at java.lang.ProcessBuilder.start(ProcessBuilder.java:452)
          	... 28 more
          
          Emmanuel Venisse added a comment -

          Fixed in r.780207


            People

            • Assignee:
              Emmanuel Venisse
              Reporter:
              Brett Porter
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: