Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.3 (Beta), 1.4.0 (Beta)
    • Fix Version/s: 1.3.3 (Beta)
    • Component/s: None
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Unable to add a secured project even with the right credentials:

      org.apache.maven.continuum.ContinuumException: Error reading POM
      at org.apache.maven.continuum.web.action.AddMavenTwoProjectAction.doExecute(AddMavenTwoProjectAction.java:151)
      at org.apache.maven.continuum.web.action.AddMavenProjectAction.execute(AddMavenProjectAction.java:189)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.opensymphony.xwork2.DefaultActionInvocation.invokeAction(DefaultActionInvocation.java:404)
      at com.opensymphony.xwork2.DefaultActionInvocation.invokeActionOnly(DefaultActionInvocation.java:267)
      at org.apache.struts2.interceptor.BackgroundProcess$1.run(BackgroundProcess.java:56)
      at java.lang.Thread.run(Thread.java:613)
      Caused by: java.net.ProtocolException: Server redirected too many times (20)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1180)
      at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:234)
      at java.net.URL.openStream(URL.java:1007)
      at org.apache.maven.continuum.web.action.AddMavenTwoProjectAction.doExecute(AddMavenTwoProjectAction.java:127)
      ... 9 more

        Activity

        Maria Catherine Tan added a comment -

        Found out that the commits made in r. 763464 is the cause.

        Olivier Lamy added a comment -

        I don't really understand why we read pom in the webapp part.
        IMHO this must be done only in core part.
        rev 763464 must be reverted !

        Jevica Arianne B. Zurbano added a comment -

        r763464 has been reverted.


          People

          • Assignee:
            Unassigned
            Reporter:
            Maria Catherine Tan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: