Continuum
  1. Continuum
  2. CONTINUUM-2177

NPE when building some projects in build agent

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.3.2 (Beta)
    • Fix Version/s: 1.3.4 (Beta)
    • Component/s: Distributed Builds
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      I'm getting the following NPEs when building some of the Maven 2 Plugins in a build agent. The plugins are building fine in the server when distributed builds is disabled though.

      2009-04-17 17:33:58,177 [pool-1-thread-1] INFO org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor - Checking if project 'Maven Clean Plugin' should build
      2009-04-17 17:33:58,318 [pool-1-thread-1] ERROR org.apache.continuum.buildagent.build.execution.maven.m2.DefaultBuildAgentMavenBuilderHelper - Cannot build maven project from C:\working-directory\17\pom.xml (No bean named 'wagon#http' is defined).
      2009-04-17 17:33:58,318 [pool-1-thread-1] ERROR org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor - Error getting maven project
      org.apache.continuum.buildagent.build.execution.ContinuumAgentBuildExecutorException: Unable to read the Maven project descriptor 'C:\working-directory\17\pom.xml': No bean named 'wagon#http' is defined

      at org.apache.continuum.buildagent.build.execution.maven.m2.MavenTwoBuildExecutor.getMavenProject(MavenTwoBuildExecutor.java:275)
      at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.getMavenProject(BuildProjectTaskExecutor.java:516)
      at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.shouldBuild(BuildProjectTaskExecutor.java:406)
      at org.apache.continuum.buildagent.taskqueue.execution.BuildProjectTaskExecutor.executeTask(BuildProjectTaskExecutor.java:117)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
      at java.lang.Thread.run(Thread.java:595)

        Activity

        Brett Porter added a comment -

        I can confirm that no wagons are included in the build agent web application. This probably needs to be copied from the main webapp configuration. Can you see if that resolves the issue?

        Maria Catherine Tan added a comment -

        I tried building Maven Clean Plugin http://svn.apache.org/repos/asf/maven/plugins/trunk/maven-clean-plugin/ in build agents and it built successfully.

        This is using 1.3.x r776519

        Maria Catherine Tan added a comment -

        I cannot reproduce this using 1.3.4-SNAPSHOT r794266


          People

          • Assignee:
            Unassigned
            Reporter:
            Maria Odea Ching
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: