Continuum
  1. Continuum
  2. CONTINUUM-2175

Error when add a Maven 2 Project with file url

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.3 (Beta), 1.4.0 (Beta)
    • Fix Version/s: 1.3.3 (Beta)
    • Component/s: Web - UI
    • Labels:
      None
    • Environment:
      Firefox 3
      Ubuntu 8.10
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      In pom url dont allow pattern file:///, but if file does not exist I get an error and if path is correct I get 'The specified resource isn't a file or the protocol used isn't allowed' (correct)

      Error

      org.apache.maven.continuum.ContinuumException: Error reading POM
      
      Show/hide Stack Trace
      
              org.apache.maven.continuum.ContinuumException: Error reading POM
      	at org.apache.maven.continuum.web.action.AddMavenTwoProjectAction.doExecute(AddMavenTwoProjectAction.java:109)
      	at org.apache.maven.continuum.web.action.AddMavenProjectAction.execute(AddMavenProjectAction.java:189)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at com.opensymphony.xwork2.DefaultActionInvocation.invokeAction(DefaultActionInvocation.java:404)
      	at com.opensymphony.xwork2.DefaultActionInvocation.invokeActionOnly(DefaultActionInvocation.java:267)
      	at org.apache.struts2.interceptor.BackgroundProcess$1.run(BackgroundProcess.java:56)
      	at java.lang.Thread.run(Thread.java:619)
      Caused by: java.io.FileNotFoundException: / (Is a directory)
      	at java.io.FileInputStream.open(Native Method)
      	at java.io.FileInputStream.<init>(FileInputStream.java:106)
      	at java.io.FileInputStream.<init>(FileInputStream.java:66)
      	at java.io.FileReader.<init>(FileReader.java:41)
      	at org.apache.maven.continuum.web.action.AddMavenTwoProjectAction.doExecute(AddMavenTwoProjectAction.java:93)
      	... 9 more
      

        Activity

        Jose Morales Martinez added a comment -

        This issue was fixed in 766272.


          People

          • Assignee:
            Unassigned
            Reporter:
            Jose Morales Martinez
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: