Continuum
  1. Continuum
  2. CONTINUUM-2163

Getting an Unrecognised tag: 'scmResult' error when upgrading from 1.3.1 to 1.3.2 and 1.3.3-SNAPSHOT using data management tool

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.2 (Beta)
    • Fix Version/s: 1.3.4 (Beta)
    • Component/s: Data Management
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      Exception in thread "main" org.apache.maven.continuum.management.DataManagementException: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[673,22]
      Message: Unrecognised tag: 'scmResult'
      at org.apache.maven.continuum.management.JdoDataManagementTool.restoreDatabase(JdoDataManagementTool.java:231)
      at org.apache.maven.continuum.management.DataManagementCli.processDatabase(DataManagementCli.java:270)
      at org.apache.maven.continuum.management.DataManagementCli.main(DataManagementCli.java:170)
      Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[673,22]
      Message: Unrecognised tag: 'scmResult'
      at org.apache.maven.continuum.model.project.io.stax.ContinuumStaxReader.parseProject(ContinuumStaxReader.java:2638)
      at org.apache.maven.continuum.model.project.io.stax.ContinuumStaxReader.parseProjectGroup(ContinuumStaxReader.java:2846)
      at org.apache.maven.continuum.model.project.io.stax.ContinuumStaxReader.parseContinuumDatabase(ContinuumStaxReader.java:1354)
      at org.apache.maven.continuum.model.project.io.stax.ContinuumStaxReader.read(ContinuumStaxReader.java:3713)
      at org.apache.maven.continuum.model.project.io.stax.ContinuumStaxReader.read(ContinuumStaxReader.java:3729)
      at org.apache.maven.continuum.management.JdoDataManagementTool.restoreDatabase(JdoDataManagementTool.java:227)
      ... 2 more

      This happens because 'scmResult' field in the Project was removed starting in 1.3.2

      1. builds.xml
        16 kB
        Maria Catherine Tan

        Issue Links

          Activity

          Brett Porter added a comment -

          do you have a dataset handy for this?

          I think we need to change the CLI to use a more flexible parsing that will just ignore extra elements for situations like this.

          Maria Catherine Tan added a comment -

          attached sample builds.xml of continuum 1.3.1

          Maria Catherine Tan added a comment - - edited

          setting strict to false of ContinuumStaxReader.read( Reader reader, boolean strict ) used to work...wonder what changed?

          I'm now getting this error:

          Exception in thread "main" org.apache.maven.continuum.management.DataManagementException: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[251,27]
          Message: expected XMLStreamConstants.START_ELEMENT or XMLStreamConstants.END_ELEMENT not CHARACTERS
          at org.apache.maven.continuum.management.JdoDataManagementTool.restoreDatabase(JdoDataManagementTool.java:255)
          at org.apache.maven.continuum.management.DataManagementCli.processDatabase(DataManagementCli.java:277)
          at org.apache.maven.continuum.management.DataManagementCli.main(DataManagementCli.java:173)
          Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[251,27]
          Message: expected XMLStreamConstants.START_ELEMENT or XMLStreamConstants.END_ELEMENT not CHARACTERS
          at com.bea.xml.stream.MXParser.nextTag(MXParser.java:1220)
          at org.apache.maven.continuum.model.project.io.stax.ContinuumStaxReader.parseProject(ContinuumStaxReader.java:2373)
          at org.apache.maven.continuum.model.project.io.stax.ContinuumStaxReader.parseProjectGroup(ContinuumStaxReader.java:2909)
          at org.apache.maven.continuum.model.project.io.stax.ContinuumStaxReader.parseContinuumDatabase(ContinuumStaxReader.java:1354)
          at org.apache.maven.continuum.model.project.io.stax.ContinuumStaxReader.read(ContinuumStaxReader.java:3776)
          at org.apache.maven.continuum.management.JdoDataManagementTool.restoreDatabase(JdoDataManagementTool.java:251)
          ... 2 more

          Maria Catherine Tan added a comment -

          Made some changes in the CLI:
          r785095 1.3.x branch
          r785096 trunk

          • allow user to turn on/off strict mode by adding a command line argument -strict. default is false.
          Maria Catherine Tan added a comment -

          Created an issue in MODELLO and submitted a patch, which will fix the error encountered when there is an unrecognized tag and strict is set to false.

          Maria Catherine Tan added a comment -

          Fixed by upgrading modello to 1.1


            People

            • Assignee:
              Maria Catherine Tan
              Reporter:
              Maria Catherine Tan
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: