Continuum
  1. Continuum
  2. CONTINUUM-2120

Unable to build project after scm error

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.3.1 (Alpha)
    • Fix Version/s: 1.3.2 (Beta)
    • Component/s: None
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Once a project gets into the error state for the scm url, it is impossible to build the project again.

      To reproduce:
      1. Add a project to Continuum
      2. Force a build, note that both the scm url and project show success
      3. Take the Subversion repo offline, or disable the account that was used to add the project
      4. Force another build, note that the scm url is in error
      5. Bring Subversion back up, or re-enable the user account
      6. Force a build

      Expected: Continuum updates the svn checkout, the scm url goes back to success state, and the project builds

      Actual results are that nothing happens. The scm url remains in error, the project does not build, and the log shows:

      2009-03-10 15:12:14,091 [btpool0-9] INFO org.apache.continuum.buildmanager.ParallelBuildsManager - Queueing prepare-build-project task 'org.apache.continuum.taskqueue.PrepareBuildProjectsTask@8' to prepare-build queue.
      2009-03-10 15:12:14,091 [pool-7-thread-1] INFO org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor - initializing prepare build
      2009-03-10 15:12:14,107 [pool-7-thread-1] INFO org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor - Ending prepare build

        Activity

        Wendy Smoak added a comment -

        The good news is that this seems to be fixed on trunk – I can't reproduce it with 1.3.2-SNAPSHOT downloaded from vmbuild this morning.

        I'm having trouble determining exactly what fixed it, however. Assuming that it was something that touched PrepareBuildProjectsTaskExecutor since 1.3.1 was tagged, the candidates are r751864, r751433, r742493 and r740587.

        Maria Catherine Tan added a comment -

        This was fixed in r751433.

        Wendy Smoak added a comment -

        I edited the commit log for r751433 to add this issue. Thanks Marica!


          People

          • Assignee:
            Maria Catherine Tan
            Reporter:
            Wendy Smoak
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: