Continuum
  1. Continuum
  2. CONTINUUM-2021

NullPointerException when sending mail notification

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.1 (Alpha)
    • Fix Version/s: 1.3.1 (Alpha)
    • Component/s: Notifier - Mail
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      To Reproduce:
      1. Add a project group notifier 'send on success'
      2. Build project

      Result: NPE after prepare build is finished caused by empty recipients while sending mail notification.

        Activity

        Maria Catherine Tan added a comment -

        check if mail recipients is empty or not before sending the message.

        fixed in rev 727698


          People

          • Assignee:
            Maria Catherine Tan
            Reporter:
            Maria Catherine Tan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: