Continuum
  1. Continuum
  2. CONTINUUM-2003

Edit roles deletes all existing roles when sharing a user database

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.2, 1.3.5 (Beta)
    • Fix Version/s: 1.3.7, 1.4.1
    • Component/s: Core system
    • Labels:
      None
    • Environment:
      OS: Linux
      Deployed withing Tomcat and MySQL database
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Hi,

      I've installed continuum-1.2.2 and archiva-1.1.3. For both, I'm using the same "users" database schema as i do not want to create accounts twice. When I edit roles in continuum, it first deletes existing roles then add all checked roles. But, the user can also be an "Archiva repository manager" for example. So, if I want to add roles to a user, I have to do it manually, playing SQL script on DB, otherwise Archiva roles are removed.
      Note that this is the same for Archiva (editing roles in Archiva removes roles for Continuum if database is the same).

      To reproduce:

      • install continuum and archiva and give them the same schema for users
      • create a user
      • give him some roles in archiva
      • go in continuum, give him some roles and submit
      • archiva roles are removed

      David

        Issue Links

          Activity

          Brett Porter added a comment -

          is this still an issue in 1.3.x?

          it should restrict itself to the current application when doing so.

          David Degardin added a comment -

          No this seems to be resolved.

          David Degardin added a comment -

          Hello,

          I've installed Archiva-1.2.1 this morning and it seems that the bug is back (not so sure it has already disappeared actually...)
          I've got continuum-1.2.2 and archiva-1.2.1 sharing the same users database.

          For example, giving "Repository Manager" role in Archiva to a user that already has other continuum roles will delete its continuum roles (i.e user becomes only repository manager).
          Same thing for continuum: giving new continuum roles in continuum deletes archiva roles.

          This is fully repeatable.

          David

          Brett Porter added a comment -

          ok, we'll take a look.

          Brent N Atkinson added a comment -

          Brett, I believe we chatted about this a couple months ago. It requires upgrading to a patched version of redback in both products to fully address the issue. This was a redback struts2-integration bug. I just recently created the placeholder issue to ensure that archiva and continuum are updated.

          I want to make this explicit in case any users end up here:

          To escape this bug you need to run versions of archiva and continuum that include a fix. If either product is unpatched, as soon as you edit roles using the unpatched product you'll delete the roles for the other product. I've been running multiple installations (archiva 1.3/continuum 1.3.5) without issue using the patch referenced in REDBACK-253.

          Brett Porter added a comment -

          fixed in Redback, thanks Brent!


            People

            • Assignee:
              Brett Porter
              Reporter:
              David Degardin
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: