Continuum
  1. Continuum
  2. CONTINUUM-1988

Cannot build project if triggered from Project Information page

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.3.1 (Alpha)
    • Fix Version/s: 1.3.1 (Alpha)
    • Component/s: Core system
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      I'm getting the following error in the logs:

      2008-11-21 15:48:28,177 [Thread-23] ERROR taskQueueExecutor#prepare-build-project - Error executing task
      edu.emory.mathcs.backport.java.util.concurrent.ExecutionException: java.lang.RuntimeException: Missing key 'projectScmRoot'.
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.getResult(FutureTask.java:301)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.get(FutureTask.java:120)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.waitForTask(ThreadedTaskQueueExecutor.java:159)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.run(ThreadedTaskQueueExecutor.java:127)
      Caused by: java.lang.RuntimeException: Missing key 'projectScmRoot'.
      at org.apache.maven.continuum.core.action.AbstractContinuumAction.getObject(AbstractContinuumAction.java:266)
      at org.apache.maven.continuum.core.action.AbstractContinuumAction.getProjectScmRoot(AbstractContinuumAction.java:216)
      at org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor.endPrepareBuild(PrepareBuildProjectsTaskExecutor.java:250)
      at org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor.executeTask(PrepareBuildProjectsTaskExecutor.java:131)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:178)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1061)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:575)
      at java.lang.Thread.run(Thread.java:595)
      2008-11-21 15:49:48,128 [pool-7-thread-1] INFO taskExecutor#prepare-build-project - Ending prepare build
      2008-11-21 15:49:48,128 [Thread-23] ERROR taskQueueExecutor#prepare-build-project - Error executing task
      edu.emory.mathcs.backport.java.util.concurrent.ExecutionException: java.lang.RuntimeException: Missing key 'projectScmRoot'.
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.getResult(FutureTask.java:301)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.get(FutureTask.java:120)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.waitForTask(ThreadedTaskQueueExecutor.java:159)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.run(ThreadedTaskQueueExecutor.java:127)
      Caused by: java.lang.RuntimeException: Missing key 'projectScmRoot'.
      at org.apache.maven.continuum.core.action.AbstractContinuumAction.getObject(AbstractContinuumAction.java:266)
      at org.apache.maven.continuum.core.action.AbstractContinuumAction.getProjectScmRoot(AbstractContinuumAction.java:216)
      at org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor.endPrepareBuild(PrepareBuildProjectsTaskExecutor.java:250)
      at org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor.executeTask(PrepareBuildProjectsTaskExecutor.java:131)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:178)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1061)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:575)
      at java.lang.Thread.run(Thread.java:595)

      Btw, I'm using trunk 1.3-SNAPSHOT -r719458 and the project I was building is Archiva trunk version.

        Activity

        Maria Odea Ching added a comment -

        I get the same error when I build the project by clicking on the build project icon corresponding to the project in the Project Group Summary page. But if I build the project by ticking the corresponding checkbox and then click the Build Project(s) button in the Project Group Summary page, I'm able to build it.

        Maria Catherine Tan added a comment -

        Fixed in revision 720121

        Wendy Smoak added a comment -

        1.3.0 was tagged in r720086, so this will be in 1.3.1


          People

          • Assignee:
            Maria Catherine Tan
            Reporter:
            Maria Odea Ching
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: