Continuum
  1. Continuum
  2. CONTINUUM-1985

Releasing projects without local repo throws NPE

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.2.2
    • Fix Version/s: 1.2.3
    • Component/s: Core system
    • Labels:
      None
    • Environment:
      SLES 10, tomcat 6.0.16
    • Complexity:
      Intermediate
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      After upgrading to 1.2.2 from 1.1, releases on projects created before the upgrade fail. The issue appears to be that the DefaultShellCommandHelper.createCommandline doesn't handle a null argument array. The initial cause is that the upgraded projects don't have the local repo set to anything, while newly created projects have it set to DEFAULT. I am attaching a patch that takes care of the null argument list, but perhaps an upgrade should bless projects with no default repo to use DEFAULT?

      [ERROR] org.apache.maven.shared.release.ReleaseExecutionException
      at org.apache.continuum.release.phase.AbstractContinuumRunGoalsPhase.execute(AbstractContinuumRunGoalsPhase.java:70)
      at org.apache.continuum.release.phase.RunPrepareGoalsPhase.execute(RunPrepareGoalsPhase.java:47)
      at org.apache.maven.shared.release.DefaultReleaseManager.prepare(DefaultReleaseManager.java:194)
      at org.apache.maven.shared.release.DefaultReleaseManager.prepareWithResult(DefaultReleaseManager.java:107)
      at org.apache.maven.continuum.release.executors.PrepareReleaseTaskExecutor.execute(PrepareReleaseTaskExecutor.java:43)
      at org.apache.maven.continuum.release.executors.AbstractReleaseTaskExecutor.executeTask(AbstractReleaseTaskExecutor.java:67)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:178)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1061)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:575)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.NullPointerException
      at org.apache.continuum.utils.shell.DefaultShellCommandHelper.createCommandline(DefaultShellCommandHelper.java:105)
      at org.apache.continuum.utils.shell.DefaultShellCommandHelper.executeGoals(DefaultShellCommandHelper.java:176)
      at org.apache.continuum.utils.shell.DefaultShellCommandHelper.executeGoals(DefaultShellCommandHelper.java:169)
      at org.apache.continuum.release.phase.AbstractContinuumRunGoalsPhase.execute(AbstractContinuumRunGoalsPhase.java:62)
      ... 11 more

        Activity

        Brent N Atkinson added a comment -

        Just for reference, I was able to clean up the existing project groups by assigning the DEFAULT repo to all the existing project groups:

        update sa.projectgroup set local_repository_id_oid = 1 where local_repository_id_oid is null;

        Maria Catherine Tan added a comment -

        fixed in revision 719442
        merge in trunk revision 719443

        Thanks!


          People

          • Assignee:
            Maria Catherine Tan
            Reporter:
            Brent N Atkinson
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: