Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.2
    • Fix Version/s: 1.3.3 (Beta)
    • Component/s: Notifier - IRC
    • Labels:
      None
    • Complexity:
      Intermediate
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      Note: apparently not a duplicate of previous similar issues. The problem is with 1.2.

      2008-10-21 02:01:33,841 [pool-1-thread-1] INFO buildController - Performing action deploy-artifact
      2008-10-21 02:01:33,863 [Thread-16] ERROR taskQueueExecutor#build-project - Error executing task
      edu.emory.mathcs.backport.java.util.concurrent.ExecutionException: java.lang.NullPointerException
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.getResult(FutureTask.java:299)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.get(FutureTask.java:118)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.waitForTask(ThreadedTaskQueueExecutor.java:159)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.run(ThreadedTaskQueueExecutor.java:127)
      Caused by: java.lang.NullPointerException
      at org.apache.maven.continuum.notification.AbstractContinuumNotifier.getPreviousBuild(AbstractContinuumNotifier.java:244)
      at org.apache.maven.continuum.notification.irc.IrcContinuumNotifier.buildComplete(IrcContinuumNotifier.java:272)
      at org.apache.maven.continuum.notification.irc.IrcContinuumNotifier.sendMessage(IrcContinuumNotifier.java:254)
      at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.sendNotification(DefaultContinuumNotificationDispatcher.java:201)
      at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.sendNotification(DefaultContinuumNotificationDispatcher.java:184)
      at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.buildComplete(DefaultContinuumNotificationDispatcher.java:96)
      at org.apache.maven.continuum.buildcontroller.DefaultBuildController.endBuild(DefaultBuildController.java:241)
      at org.apache.maven.continuum.buildcontroller.DefaultBuildController.build(DefaultBuildController.java:195)
      at org.apache.maven.continuum.buildcontroller.BuildProjectTaskExecutor.executeTask(BuildProjectTaskExecutor.java:50)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
      at java.lang.Thread.run(Thread.java:619)

        Activity

        Aaron Unger added a comment - - edited

        It appears that the IRC notification configuration was left out. If you add the following to the plexus config (apps/continuum/WEB-INF/classes/META-INF/plexus/application.xml), it should start working for you. I added it at line 156 in mine.

            <!--
            | The IRC notifier
            |-->
            <component>
              <role>org.apache.maven.continuum.notification.Notifier</role>
              <role-hint>irc</role-hint>
              <implementation>org.apache.maven.continuum.notification.irc.IrcContinuumNotifier</implementation>
              <requirements>
                <requirement>
                  <role>org.apache.maven.continuum.configuration.ConfigurationService</role>
                </requirement>
                <requirement>
                  <role>org.apache.continuum.dao.ProjectDao</role>
                </requirement>
                <requirement>
                  <role>org.apache.continuum.dao.BuildResultDao</role>
                </requirement>
              </requirements>
              <configuration>
                <alwaysSend>false</alwaysSend>
              </configuration>
            </component>
        
        Aaron Unger added a comment -

        Patch to insert the IRC notification config into the plexus config file.

        Stephan Heinze added a comment -

        Thanks a lot. Works for me.

        Julien S added a comment -

        Thanks Aaron. It works like a charm.

        Brett Porter added a comment -

        patch to review, I get this on vmbuild as well

        seen on vmbuild:

        2009-03-13 22:22:34,362 [Thread-16] ERROR taskQueueExecutor#build-project  - Error executing task
        edu.emory.mathcs.backport.java.util.concurrent.ExecutionException: java.lang.NullPointerException
                at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.getResult(FutureTask.java:301)
                at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.get(FutureTask.java:130)
                at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.waitForTask(ThreadedTaskQueueExecutor.java:165)
                at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.run(ThreadedTaskQueueExecutor.java:127)
        Caused by: java.lang.NullPointerException
                at org.apache.maven.continuum.notification.AbstractContinuumNotifier.getPreviousBuild(AbstractContinuumNotifier.java:244)
                at org.apache.maven.continuum.notification.irc.IrcContinuumNotifier.buildComplete(IrcContinuumNotifier.java:272)
                at org.apache.maven.continuum.notification.irc.IrcContinuumNotifier.sendMessage(IrcContinuumNotifier.java:254)
                at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.sendNotification(DefaultContinuumNotificationDispatcher.java:201)
                at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.sendNotification(DefaultContinuumNotificationDispatcher.java:184)
                at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.buildComplete(DefaultContinuumNotificationDispatcher.java:96)
                at org.apache.maven.continuum.buildcontroller.DefaultBuildController.endBuild(DefaultBuildController.java:241)
                at org.apache.maven.continuum.buildcontroller.DefaultBuildController.build(DefaultBuildController.java:195)
                at org.apache.maven.continuum.buildcontroller.BuildProjectTaskExecutor.executeTask(BuildProjectTaskExecutor.java:50)
        

        this may be the same/similar to CONTINUUM-1548, but it doesn't provide details

        Maria Catherine Tan added a comment -

        Irc notification is working in 1.3.2-SNAPSHOT rev 756373. Removing 1.3.2 from the fix version

        Emmanuel Venisse added a comment -

        Cannot reproduce in 1.3.3


          People

          • Assignee:
            Emmanuel Venisse
            Reporter:
            Julien S
          • Votes:
            2 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: