Continuum
  1. Continuum
  2. CONTINUUM-1909

login and password ignored in checkout operation

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.2.2
    • Fix Version/s: 1.3.2 (Beta)
    • Component/s: SCM
    • Labels:
      None
    • Environment:
      Windows, mac, unix
    • Complexity:
      Intermediate
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      This is what I see in continuum.log:

      2008-10-01 02:00:04,248 [pool-1-thread-1] INFO action#checkout-project - Checking out project: 'RNP', id: '6' to 'C:\apache\apache-continuum-1.3-SNAPSHOT\target\working-directory\6' with branch/tag .
      2008-10-01 02:00:04,405 [pool-1-thread-1] INFO org.apache.continuum.scm.manager.Slf4jScmLogger - Executing: cmd.exe /X /C "svn --non-interactive checkout svn://server.com/RNP/trunk 6"
      2008-10-01 02:00:04,405 [pool-1-thread-1] INFO org.apache.continuum.scm.manager.Slf4jScmLogger - Working directory: C:\apache\apache-continuum-1.3-SNAPSHOT\target\working-directory
      2008-10-01 02:00:06,998 [pool-1-thread-1] WARN action#checkout-project - Error while checking out the code for project: 'RNP', id: '6' to 'C:\apache\apache-continuum-1.3-SNAPSHOT\target\working-directory\6' with branch/tag .
      2008-10-01 02:00:06,998 [pool-1-thread-1] WARN action#checkout-project - Command output: svn: Authorization failed

      Authorization failed because cmd.exe is executed with svn WITHOUT --user and --password options.

      Why so?

        Issue Links

          Activity

          Carlos Sanchez added a comment -

          Reproduced for the perforce scm in continuum 1.2.2

          I think the problem may happen when you add a project without user/password, project fails to checkout, edit project to add user/passwd, continuum doesnt use that information

          Carlos Sanchez added a comment -

          Patch against continuum 1.2.2

          Olivier Lamy added a comment -

          Move to fix version 1.3.1 as we need here a new maven-scm version.
          Carlos your patch looks correct. You don't have karma here ??

          Carlos Sanchez added a comment -

          i have, but not sure if it could break something else

          Emmanuel Venisse added a comment -

          Applied in r.752948


            People

            • Assignee:
              Emmanuel Venisse
              Reporter:
              Jimmy Conway
            • Votes:
              2 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: