Continuum
  1. Continuum
  2. CONTINUUM-1887

Release rollback hangs when the release failed at the scm-check-modifications phase

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.3.2 (Beta)
    • Component/s: Release
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      To reproduce
      1. introduce a local change to the working copy
      2. attempt to release the project
      3. release fails at the scm-check-modifications phase
      4. click Rollback
      5. Confirm rollback

      Result:
      Web UI hangs at "Opening page ... releaseRollback.action"
      Stack trace in log
      ...
      INFO | jvm 1 | 2008/09/18 14:59:24 | 2008-09-18 14:59:24,178 [pool-5-thread-1] ERROR taskQueueExecutor#rollback-release - Error executing task
      INFO | jvm 1 | 2008/09/18 14:59:24 | org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Failed to rollback release
      ...
      INFO | jvm 1 | 2008/09/18 14:59:24 | Caused by: org.apache.maven.shared.release.ReleaseExecutionException: Cannot restore from a missing backup POM: /path/to/continuum/working-directory/2/pom.xml.releaseBackup

      It should be able to roll back from a failure at any point, or the rollback button should be disabled if it's not relevant.

        Issue Links

          Activity

          Maria Catherine Tan added a comment -

          Fixed in revision 755119 by updating listener when release rollback failed so it won't hang.


            People

            • Assignee:
              Maria Catherine Tan
              Reporter:
              Wendy Smoak
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: