Continuum
  1. Continuum
  2. CONTINUUM-1825

NPE when checkout project with trunk (rev 678311)

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2
    • Component/s: None
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      When I add a new project, I have the following stack trace :

      2008-07-21 11:42:29,420 [pool-2-thread-1] ERROR taskQueueExecutor#check-out-project  - Error executing task
      org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Error checking out project.
              at org.apache.maven.continuum.scm.queue.CheckOutTaskExecutor.executeTask(CheckOutTaskExecutor.java:102)
              at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
              at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
              at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
              at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
              at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
              at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.NullPointerException
              at org.apache.maven.continuum.notification.AbstractContinuumNotifier.getBuildOutput(AbstractContinuumNotifier.java:66)
              at org.apache.maven.continuum.notification.mail.MailContinuumNotifier.sendMessage(MailContinuumNotifier.java:242)
              at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.sendNotification(DefaultContinuumNotificationDispatcher.java:195)
              at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.sendNotification(DefaultContinuumNotificationDispatcher.java:178)
              at org.apache.maven.continuum.notification.DefaultContinuumNotificationDispatcher.checkoutComplete(DefaultContinuumNotificationDispatcher.java:75)
              at org.apache.maven.continuum.core.action.CheckoutProjectContinuumAction.execute(CheckoutProjectContinuumAction.java:188)
              at org.apache.maven.continuum.scm.queue.CheckOutTaskExecutor.executeTask(CheckOutTaskExecutor.java:96)
              ... 6 more
      

        Activity

        Olivier Lamy added a comment -

        fix in rev 678536


          People

          • Assignee:
            Olivier Lamy
            Reporter:
            Olivier Lamy
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: