Continuum
  1. Continuum
  2. CONTINUUM-1823

Fewer notifications when Subversion server is unreachable

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3.2 (Beta)
    • Component/s: None
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      By default Continuum sends notifications when the state of a project changes, so two consecutive build failures will result in only one email. However, when the build failure is caused by an unreachable Subversion server a notification is sent every hour, for every project (See output below). This resulted in approx. 1500 emails in my ci-folder after the weekend. Which, imho, is a bit unfortunate.

      Would it be possible to adopt the principle advocated by TestNG; that this is caused by a single failure and all other failures are derived failures which are given the status SKIPPED in TestNG terminology?

      In other words, I propose the following extension:

      Create a list of SCM-repositories known to Continuum.
      Run a simple availability test on each of these and set status "OK" or "Unavailable".
      Projects that use an unavailable repository can thus be SKIPPED until the repository is available again.
      The repository test can be run e.g. once an hour (preferable configurable) and should only send notifications when the state changes.

      Further, it would be nice if it was possible to set up a list of notifiers separate from the project notifiers like it is for projects now. It would typically be interesting for system administrators to subscribe to email notifications for unavailable SCM repo. (A cheap surveillance solution.)

      Build Error:
      ****************************************************************************
      Provider message: The svn command failed.
      Command output: -------------------------------------------------------------------------------
      svn: PROPFIND request failed on '/svn/projectName/trunk/'
      svn: PROPFIND of '/svn/projectName/trunk/': could not connect to server (https://10.0.0.10)

        Issue Links

          Activity

          Brett Porter added a comment -

          I think this is generally the direction we've wanted to go (there are several already scheduled issues to improve duplicate reporting, and to separate transient errors from build errors both in the UI and notifications). If you'd like to help out - we'd be happy to discuss this on dev@continuum.apache.org.

          Wendy Smoak added a comment -

          It looks like CONTINUUM-634 would address the "for every project" part of the complaint, but not the "every hour" part, so I don't think this is a complete duplicate.

          As mentioned on the dev list, after the transient state changes (CONTINUUM-1864, CONTINUUM-1829,) I'm still seeing a notification for every scheduled build using the 'bad-scm' example project. I can't take svn down, so I'm using a project with an intentionally incorrect svn url to simulate it. Another way to test this is to disable the subversion user account after adding the project so that you get an authorization error when it tries to build.

          http://www.nabble.com/Repeated-%27PREPARE-BUILD-ERROR%27-notifications-td22416935.html

          Maria Catherine Tan added a comment -

          Fixed in revision 752320.

          • added a check to see if the scm root previous state is the same as the current state before sending the notification

            People

            • Assignee:
              Maria Catherine Tan
              Reporter:
              Erik Drolshammer
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: