Continuum
  1. Continuum
  2. CONTINUUM-1814

release prepare : when generate-reactor-projects can't resolve transitively dependency.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: 1.3.6
    • Component/s: Release
    • Labels:
      None
    • Environment:
      maven 2.0.7, subversion 1.4.2
    • Complexity:
      Intermediate
    • Number of attachments :
      3

      Description

      [INFO] Updating local copy against the scm...
      [ERROR] org.apache.maven.shared.release.ReleaseExecutionException: Unable to get reactor projects: Failed to build project.
      at org.apache.maven.continuum.release.phase.GenerateReactorProjectsPhase.execute(GenerateReactorProjectsPhase.java:82)
      at org.apache.maven.shared.release.DefaultReleaseManager.prepare(DefaultReleaseManager.java:194)
      at org.apache.maven.shared.release.DefaultReleaseManager.prepareWithResult(DefaultReleaseManager.java:107)
      at org.apache.maven.continuum.release.executors.PrepareReleaseTaskExecutor.execute(PrepareReleaseTaskExecutor.java:43)
      at org.apache.maven.continuum.release.executors.AbstractReleaseTaskExecutor.executeTask(AbstractReleaseTaskExecutor.java:67)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:665)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:690)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: org.apache.maven.continuum.release.ContinuumReleaseException: Failed to build project.
      at org.apache.maven.continuum.release.phase.GenerateReactorProjectsPhase.addModules(GenerateReactorProjectsPhase.java:169)
      at org.apache.maven.continuum.release.phase.GenerateReactorProjectsPhase.getReactorProjects(GenerateReactorProjectsPhase.java:109)
      at org.apache.maven.continuum.release.phase.GenerateReactorProjectsPhase.execute(GenerateReactorProjectsPhase.java:78)
      ... 10 more
      Caused by: org.apache.maven.artifact.resolver.MultipleArtifactsNotFoundException: Missing:
      ----------
      1) fr.paris.lutece:lutece-core:lutece-core:2.1.2

      Try downloading the file manually from the project website.

      Then, install it using the command:
      mvn install:install-file -DgroupId=fr.paris.lutece -DartifactId=lutece-core \
      -Dversion=2.1.2 -Dpackaging=lutece-core -Dfile=/path/to/file

      Path to dependency:
      1) fr.paris.lutece.plugins:lutece-plugins-pom:pom:2.6-SNAPSHOT
      2) fr.paris.lutece.plugins:library-lutece-unit-testing:jar:2.0.2
      3) fr.paris.lutece:lutece-core:lutece-core:2.1.2

      ----------
      1 required artifact is missing.

      for artifact:
      fr.paris.lutece.plugins:lutece-plugins-pom:pom:2.6-SNAPSHOT

      from the specified remote repositories:
      central (http://repo1.maven.org/maven2),
      codehausSnapshots (http://snapshots.maven.codehaus.org/maven2),
      lutece (http://dev.lutece.paris.fr/maven_repository),
      luteceSnapshot (http://dev.lutece.paris.fr/snapshot_repository)

      at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTransitively(DefaultArtifactResolver.java:305)
      at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTransitively(DefaultArtifactResolver.java:272)
      at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTransitively(DefaultArtifactResolver.java:253)
      at org.apache.maven.project.DefaultMavenProjectBuilder.buildWithDependencies(DefaultMavenProjectBuilder.java:367)
      at org.apache.maven.project.DefaultMavenProjectBuilder.buildWithDependencies(DefaultMavenProjectBuilder.java:315)
      at org.apache.maven.continuum.release.phase.GenerateReactorProjectsPhase.addModules(GenerateReactorProjectsPhase.java:151)
      ... 12 more

      the Artifact is in my repository and in my local repository.

        Activity

        Brett Porter added a comment -

        is there anything using the dependency artifacts that relies on them being resolved?

        Maria Odea Ching added a comment -

        I tried reproducing this using the attached project and the build fails in ear-module when I built it on Continuum. It wasn't able to resolve the har-module jar because of the custom type. When I built the project from the root dir in the command line, everything builds successfully. But if I build each module individually, I also get the same error (failed to resolve artifact) in ear-module from the command-line.

        Continuum builds each module/project separately that's why the build is failing in Continuum as well. Did you encounter the same problem if just building the project?

        To get to the releasing part, I changed the default build defs to just run 'clean' in order to get a successful build for ear-module. I also encountered the same error posted above during release:prepare.

        Maria Odea Ching added a comment - - edited

        Moving up the jboss-packaging-maven-plugin config from har-module to the root pom in the test project fixed the build error when building each module/project individually. The failed to resolve artifact error still encountered during release:prepare.

        Maria Odea Ching added a comment -

        I think it is sufficient to use MavenProjectBuilder#build(...) instead of MavenProjectBuilder#buildWithDependencies(...) since we only need to get the projects to be added to the reactor in the GenerateReactorProjectsPhase and not the transitive dependencies.

        Thanks for the patches Sebastian and Brent! I applied CONTINUUM-1814.patch to trunk -r917918.

        Maria Odea Ching added a comment -

        Changing fix version to 1.3.6. Merged the changes to 1.3.x branch -r917967.


          People

          • Assignee:
            Maria Odea Ching
            Reporter:
            jsteve
          • Votes:
            5 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: