Continuum
  1. Continuum
  2. CONTINUUM-1644

Test failures occur in tagged sources

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.1
    • Fix Version/s: 1.2
    • Component/s: None
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      I checked out the sources of continuum 1.1 and tried to build it, but I encountered a test failure in continuum-api:

      $ svn co http://svn.apache.org/repos/asf/maven/continuum/tags/continuum-1.1
      $ cd continuum-1.1
      $ mvn clean install
      
      [INFO] ----------------------------------------------------------------------------
      [INFO] Building Continuum API
      [INFO]    task-segment: [clean, install]
      [INFO] ----------------------------------------------------------------------------
      [INFO] [clean:clean]
      [INFO] Deleting directory /home/nramirez/src/continuum-1.1/continuum-api/target
      [INFO] [remote-resources:process {execution: default}]
      [INFO] [resources:resources]
      [INFO] Using default encoding to copy filtered resources.
      [INFO] [compiler:compile]
      [INFO] Compiling 37 source files to /home/nramirez/src/continuum-1.1/continuum-api/target/classes
      [INFO] [resources:testResources]
      [INFO] Using default encoding to copy filtered resources.
      [INFO] [compiler:testCompile]
      [INFO] Compiling 2 source files to /home/nramirez/src/continuum-1.1/continuum-api/target/test-classes
      [INFO] [surefire:test]
      [INFO] Surefire report directory: /home/nramirez/src/continuum-1.1/continuum-api/target/surefire-reports
      
      -------------------------------------------------------
       T E S T S
      -------------------------------------------------------
      Running org.apache.maven.continuum.project.builder.AbstractContinuumProjectBuilderTest
      Tests run: 1, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 0.044 sec <<< FAILURE!
      Running org.apache.maven.continuum.utils.ContinuumUtilsTest
      Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.013 sec
      
      Results :
      
      Failed tests:
        warning(junit.framework.TestSuite$1)
      
      Tests run: 2, Failures: 1, Errors: 0, Skipped: 0
      
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] There are test failures.
      
      Please refer to /home/nramirez/src/continuum-1.1/continuum-api/target/surefire-reports for the individual test results.
      [INFO] ------------------------------------------------------------------------
      [INFO] For more information, run Maven with the -e switch
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 21 seconds
      [INFO] Finished at: Fri Feb 01 17:19:29 PHT 2008
      [INFO] Final Memory: 28M/115M
      [INFO] ------------------------------------------------------------------------
      

      I think this was caused by using maven-surefire-plugin:2.4, when it builds with version 2.3 before.

        Activity

        Nap Ramirez added a comment -

        This patch locks the version of the maven-surefire-plugin used.

        Olivier Lamy added a comment -

        We can't modify a tagged version
        Now in the current trunk all plugin versions are locked and all tests are fine.


          People

          • Assignee:
            Olivier Lamy
            Reporter:
            Nap Ramirez
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: