Continuum
  1. Continuum
  2. CONTINUUM-1635

Manage configurable number of parallel build queues

    Details

    • Type: Wish Wish
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: 1.3.1 (Alpha)
    • Component/s: Core system, Database
    • Labels:
      None
    • Environment:
      Any
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Continuum should be able to manage a configurable number of parallel checkout and build queues.
      At the moment, the only way I have found to achieve that is to duplicate the continuum plexus webapp JAR, and configure each instance with its own context URL and to store its data in a separate continuum database, all sharing the same users database.

      This allows for less contention on the (currently unique) build queue.

      -Olivier

        Issue Links

          Activity

          Wendy Smoak added a comment -

          Possible duplicate of CONTINUUM-265, or at least related.

          We need to be careful with concurrent builds for Maven 2 projects; they would need separate local repositories.

          http://docs.codehaus.org/display/MAVEN/Local+repository+separation

          deckrider added a comment -

          I urgently need this also.

          There should be configuration to permit N number of concurrent builds, and for each one defined, a different local repository must be specified, or at least a different settings.xml, which then could specify a different repository.

          This will avoid any problem with waiting until MNG-2802 is fixed.

          deckrider added a comment -

          I see in http://continuum.apache.org/docs/1.2/release-notes.html that "now it's possible to configure a local m2 repository per project group". This is excellent!

          Now as an interim measure, can each project group run builds in parallel with other project groups?

          Maria Odea Ching added a comment -

          Closing issue since this is already covered in the implementation of CONTINUUM-265.


            People

            • Assignee:
              Maria Odea Ching
              Reporter:
              Olivier Dehon
            • Votes:
              4 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: