Continuum
  1. Continuum
  2. CONTINUUM-1572

Release should support Build Environments (formerly called Continuum Profiles)

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1-beta-4, 1.1
    • Fix Version/s: 1.2.1
    • Component/s: Core - Profiles, Release
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Currently there's no way to specify parameters for the release, like JVM version or MAVEN_OPTS. I had a hard time "configuring" Maven to have enough memory during the release (actually I had to add MAVEN_OPTS=-Xmx512m as an environment variable – not a really nice solution).

      It would be nice to have a similar build configuration for the release as we have for other builds, with profiles and all. Maybe a default schedule called RELEASE would do.

        Issue Links

          Activity

          Maria Catherine Tan added a comment -

          unable to rollback

          Luc Willems added a comment -
          • initial "prepare" failure was caused by a minor issues in my test so build failed because of this
          • My "normal" build defenitions had the -Dmaven.test.skip=1 option but the release:prepare step not (which is normal )
          • once i noticed this problem and i got my working copy back OK (al version = xxx-snapshot), i retried to see if rollback could solve this problem.
            just to check that i can go back to a valid state after a prepare error
          • this is the point where i got the ClassCastException exception and rollback failed ;-(
          • manually put the working copy back into good state
          • run de prepare step with extra -Dmaven.test.skip=1 parameter -> OK
          • run the release step with extra -Dmaven.test.skip=1 parameter -> OK

          so i have 1 successfull release done
          still feels a little bit fragile , many things can go wrong ,even if your builds are OK
          rollback doesn't seems to fix the problem always ;-(

          luc

          Maria Catherine Tan added a comment -

          fixed rollback in rev 702680

          Luc Willems added a comment -

          hello,

          i was testing the rollback fix , it seems to work but no feedback is given after clicking the rollback button.
          the cursor stays in a "waiting" state , screen doesn change.

          pressing again rollback , gives this exception.
          2008-10-08 21:00:25,008 [pool-5-thread-1] ERROR taskQueueExecutor#rollback-release - Error executing task
          org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Failed to rollback release
          at org.apache.maven.continuum.release.executors.RollbackReleaseTaskExecutor.execute(RollbackReleaseTaskExecutor.java:45)
          at org.apache.maven.continuum.release.executors.AbstractReleaseTaskExecutor.executeTask(AbstractReleaseTaskExecutor.java:67)
          at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
          at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
          at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:178)
          at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1061)
          at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:575)
          at java.lang.Thread.run(Thread.java:619)
          Caused by: org.apache.maven.shared.release.ReleaseExecutionException: Cannot restore from a missing backup POM: /home/luc/src/continuum/continuum-webapp/data/working-directory/1/pom.xml.releaseBackup
          at org.apache.maven.shared.release.phase.RestoreBackupPomsPhase.restorePomBackup(RestoreBackupPomsPhase.java:90)
          at org.apache.maven.shared.release.phase.RestoreBackupPomsPhase.execute(RestoreBackupPomsPhase.java:69)
          at org.apache.maven.shared.release.DefaultReleaseManager.rollback(DefaultReleaseManager.java:248)
          at org.apache.maven.continuum.release.executors.RollbackReleaseTaskExecutor.execute(RollbackReleaseTaskExecutor.java:40)
          ... 7 more

          2008-10-08 21:00:26,775 [pool-1-thread-1] INFO continuumBuildExecutor#maven2 - Exit code: 0

          which is "normal" because rollback was already performed.
          is it possible to show some feedback of the rollback action to prevent this kind of errors.

          luc

          Wendy Smoak added a comment -

          There are known issues with release rollback, see CONTINUUM-1887 for example.


            People

            • Assignee:
              Maria Catherine Tan
              Reporter:
              Lóránt Pintér
            • Votes:
              5 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: