Continuum
  1. Continuum
  2. CONTINUUM-1562

NullPointerException when saving project

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.1-beta-4
    • Fix Version/s: 1.2.1
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows 2004 server installation
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      I have three Continuum instances running now and for one of them there seems to be some state issue when attempting to add a module to a project group. There is no problem adding modules to the other two instances.

      When invoking this operation I get a NullPointerException (see the attachment).

        Activity

        Kevin Christmas added a comment -

        I cloned CONTINUUM-1265 which seems to be the same issue. I am currently using 1.1-beta-4 however.

        This issue has been driving me crazy for the last few days, but I think I've been able to figure out how to recreate it.

        It problem manifests itself when you initially add a multi-module pom.xml file. After all main project and sub projects (inherits from parent) loads, I add a notifications section to the parent pom.xml and commit it to subversion. Continuum is unable to deal the added notifications section and neither the parent project or child projects can be saved.

        Emmanuel Venisse added a comment -

        Can you explain how to reproduce this issue? I tried and I can't.

        Kevin Christmas added a comment - - edited

        I am struggling to recreate this issue with sample projects.

        My company has a fairly large product that we've set up like this:

        pom.xml
        ----> libraries/pom.xml
        ---------> library1/pom.xml
        ---------> library2/pom.xml
        ---------> library3/pom.xml
        ---------> libraryN/pom.xml
        ----> webmodules/pom.xml
        ---------> webmodule1/pom.xml
        ---------> webmodule2/pom.xml
        ---------> webmodule3/pom.xml
        ---------> webmoduleN/pom.xml

        After initially adding the root pom.xml and letting continuum load and build the rest, adding a notifications section to the root pom.xml will place continuum in a state where none of the projects in the tree can be saved to the database. Projects not in that inheritance chain will be unaffected, meaning you can still save them to the continuum database.

        I can reproduce this error 100% of the time with my company's project.

        I would love to scratch my own itch on this, but I'm struggling to see how the StoreManager on the StateManagerImpl class gets set in the first place.

        Emmanuel Venisse added a comment -

        Cannot reproduce with 1.2


          People

          • Assignee:
            Emmanuel Venisse
            Reporter:
            Kevin Christmas
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: