Continuum
  1. Continuum
  2. CONTINUUM-1525

Can't release project with Continuum on Geronimo 2.0.1

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.1-beta-3
    • Fix Version/s: 1.2
    • Component/s: Documentation
    • Labels:
      None
    • Environment:
      Linux
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      I've installed Continuum on Geronimo 2.0.1
      Everything works fine except realese.

      When i want to relese there is en exception during "rewrite-poms-for-release":

      [INFO] Updating local copy against the scm...
      [INFO] Verifying that there are no local modifications...
      [INFO] Checking dependencies and plugins for snapshots ...
      [ERROR] org.apache.maven.shared.release.ReleaseExecutionException: Unable to locate dependency to process in document
      at org.apache.maven.shared.release.phase.AbstractRewritePomsPhase.updateDomVersion(AbstractRewritePomsPhase.java:597)
      at org.apache.maven.shared.release.phase.AbstractRewritePomsPhase.rewriteDependencies(AbstractRewritePomsPhase.java:352)
      at org.apache.maven.shared.release.phase.AbstractRewritePomsPhase.transformDocument(AbstractRewritePomsPhase.java:223)
      at org.apache.maven.shared.release.phase.AbstractRewritePomsPhase.transformProject(AbstractRewritePomsPhase.java:180)
      at org.apache.maven.shared.release.phase.AbstractRewritePomsPhase.transform(AbstractRewritePomsPhase.java:116)
      at org.apache.maven.shared.release.phase.AbstractRewritePomsPhase.execute(AbstractRewritePomsPhase.java:99)
      at org.apache.maven.shared.release.DefaultReleaseManager.prepare(DefaultReleaseManager.java:194)
      at org.apache.maven.shared.release.DefaultReleaseManager.prepareWithResult(DefaultReleaseManager.java:107)
      at org.apache.maven.continuum.release.executors.PrepareReleaseTaskExecutor.execute(PrepareReleaseTaskExecutor.java:43)
      at org.apache.maven.continuum.release.executors.AbstractReleaseTaskExecutor.executeTask(AbstractReleaseTaskExecutor.java:67)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:665)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:690)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: org.jdom.JDOMException: java.lang.NoClassDefFoundError: org/jdom/Parent: org/jdom/Parent
      at org.jdom.xpath.XPath.newInstance(XPath.java:139)
      at org.apache.maven.shared.release.phase.AbstractRewritePomsPhase.getDependencies(AbstractRewritePomsPhase.java:433)
      at org.apache.maven.shared.release.phase.AbstractRewritePomsPhase.updateDomVersion(AbstractRewritePomsPhase.java:478)
      ... 15 more
      Caused by: java.lang.NoClassDefFoundError: org/jdom/Parent
      at org.jaxen.jdom.JDOMXPath.<init>(JDOMXPath.java:91)
      at org.jdom.xpath.JaxenXPath.setXPath(JaxenXPath.java:281)
      at org.jdom.xpath.JaxenXPath.<init>(JaxenXPath.java:99)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
      at org.jdom.xpath.XPath.newInstance(XPath.java:129)
      ... 17 more

      I've added jdom-1.0.jar to the servers lib, but it didn't help

        Activity

        Maria Odea Ching added a comment -
        Brett Porter added a comment -

        need to document the workaround Deng has highlighted in the docs or wiki

        Maria Odea Ching added a comment -

        I'll add the workaround in the docs

        Maria Odea Ching added a comment -

        Fixed in contrinuum-trunk -r660359.

        • added in the docs the workaround for the jdom problem when deploying in geronimo

          People

          • Assignee:
            Maria Odea Ching
            Reporter:
            Sebastian Bloch
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: