Continuum
  1. Continuum
  2. CONTINUUM-1513

Release does not work when maven 2 executable is not on PATH

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1-beta-3
    • Fix Version/s: 1.3.1 (Alpha)
    • Component/s: Environmental
    • Labels:
      None
    • Environment:
      Maven 2 executable NOT ON PATH, just on profile
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      When trying to release a project, when maven 2 is not on the path, the following error occurs:

      [INFO] Updating local copy against the scm...
      [INFO] Verifying that there are no local modifications...
      [INFO] Checking dependencies and plugins for snapshots ...
      [INFO] Transforming 'aarh-bridge_visao'...
      [INFO] Not generating release POMs
      [ERROR] org.apache.maven.shared.release.ReleaseExecutionException: Maven execution failed, exit code: '127'
      at org.apache.maven.shared.release.phase.AbstractRunGoalsPhase.execute(AbstractRunGoalsPhase.java:66)
      at org.apache.maven.shared.release.phase.RunPrepareGoalsPhase.execute(RunPrepareGoalsPhase.java:42)
      at org.apache.maven.shared.release.DefaultReleaseManager.prepare(DefaultReleaseManager.java:194)
      at org.apache.maven.shared.release.DefaultReleaseManager.prepareWithResult(DefaultReleaseManager.java:107)
      at org.apache.maven.continuum.release.executors.PrepareReleaseTaskExecutor.execute(PrepareReleaseTaskExecutor.java:43)
      at org.apache.maven.continuum.release.executors.AbstractReleaseTaskExecutor.executeTask(AbstractReleaseTaskExecutor.java:67)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:665)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:690)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: org.apache.maven.shared.release.exec.MavenExecutorException: Maven execution failed, exit code: '127'
      at org.apache.maven.shared.release.exec.ForkedMavenExecutor.executeGoals(ForkedMavenExecutor.java:103)
      at org.apache.maven.shared.release.exec.ForkedMavenExecutor.executeGoals(ForkedMavenExecutor.java:121)
      at org.apache.maven.shared.release.phase.AbstractRunGoalsPhase.execute(AbstractRunGoalsPhase.java:59)
      ... 11 more
      

      It appears that the continuum release feature do not respect the build profile for maven 2.
      Attached is the log file.

        Issue Links

          Activity

          Marc Lustig added a comment -

          It still occurs in Continuum 1.2.2 like this:

          [INFO] Updating local copy against the scm...
          [INFO] Verifying that there are no local modifications...
          [INFO] Checking dependencies and plugins for snapshots ...
          [INFO] Transforming 'uicomponents - 0.0.12-SNAPSHOT'...
          [INFO] Not generating release POMs
          [ERROR] org.apache.maven.shared.release.ReleaseExecutionException: Maven execution failed, exit code: '127'
          at org.apache.continuum.release.phase.AbstractContinuumRunGoalsPhase.execute(AbstractContinuumRunGoalsPhase.java:70)
          at org.apache.continuum.release.phase.RunPrepareGoalsPhase.execute(RunPrepareGoalsPhase.java:47)
          at org.apache.maven.shared.release.DefaultReleaseManager.prepare(DefaultReleaseManager.java:194)
          at org.apache.maven.shared.release.DefaultReleaseManager.prepareWithResult(DefaultReleaseManager.java:107)
          at org.apache.maven.continuum.release.executors.PrepareReleaseTaskExecutor.execute(PrepareReleaseTaskExecutor.java:43)
          at org.apache.maven.continuum.release.executors.AbstractReleaseTaskExecutor.executeTask(AbstractReleaseTaskExecutor.java:67)
          at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
          at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
          at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:178)
          at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1061)
          at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:575)
          at java.lang.Thread.run(Thread.java:619)
          Caused by: org.apache.maven.shared.release.exec.MavenExecutorException: Maven execution failed, exit code: '127'
          at org.apache.continuum.utils.shell.DefaultShellCommandHelper.executeGoals(DefaultShellCommandHelper.java:209)
          at org.apache.continuum.utils.shell.DefaultShellCommandHelper.executeGoals(DefaultShellCommandHelper.java:169)
          at org.apache.continuum.release.phase.AbstractContinuumRunGoalsPhase.execute(AbstractContinuumRunGoalsPhase.java:62)
          ... 11 more

          Wendy Smoak added a comment -

          Does this happen even if you select a Build Environment for use during the release?

          (CONTINUUM-1572 added this ability, it should be there in 1.2.2)

          Marc Lustig added a comment -

          Yes, I selected a Build Environment, which has an IBM-jdk assigned.

          Maria Catherine Tan added a comment -

          fixed in rev 734652

          Marc Lustig added a comment -

          Is it save to install tomorrow's nightly build from vmbuild.apache.org, or is the trunk not very stable currently?

          Btw, vmbuild.apache.org doesn't show any project groups to me anymore.
          Could somebody please assign the rights.

          Maria Odea Ching added a comment -

          Hi Marc, some of the modules in vmbuild are still in error so I don't think it's wise to install the latest nightly build right now. We're also in the process of integrating distributed and parallel builds in trunk so trunk isn't stable yet as of now.

          (Sorry I don't have rights to access the users module in vmbuild as well..)


            People

            • Assignee:
              Maria Catherine Tan
              Reporter:
              George Gastaldi
            • Votes:
              8 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: