Continuum
  1. Continuum
  2. CONTINUUM-1360

Prepended semicolon in svn password does not work

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1-beta-1
    • Fix Version/s: 1.2
    • Component/s: Web interface
    • Labels:
      None
    • Environment:
      Suse Linux 10.2, 64-Bit, Java 1.6
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      If i have a prepended semicolon in my scm (Subversion) password, for example ";password" Continuum generates a faulty commandline for svn checkout.
      Before i used 1.1-alpha-2 with success. So i guess the handling of form input data has changed in 1.1-beta-1.
      I had no time to do further tests, but i guess there are problems with other special chars too.

        Issue Links

          Activity

          Jan Lisse added a comment -

          A little addition: The initial download of the pom.xml of my Maven2 project works fine using the same credentials.
          But when triggering a build the checkout fails with a faulty commandline. Svn complains about missing argument --password.

          Jan Lisse added a comment -

          Today i had some time digging into the sources and i figured out that the problem is not Continuum related but caused
          by a bug in the maven-scm-provider-svnexe. It does not properly quote passwords used on the commandline.
          I created a JIRA issue for it here: http://jira.codehaus.org/browse/SCM-334 and attached a patch to fix it.
          Continuum should upgrade to a new mvn-scm-provider-svnexe version as soon as a new release with the fix is available.

          Emmanuel Venisse added a comment -

          I don't think you can connect to your svn from the command line with a pretented semicolon, right?

          Rahul Thakur added a comment -

          I am not sure, but need to test this by setting up a user with such a password.

          Olivier Lamy added a comment -

          IMHO this works : svn up --username test --password ';password'
          This should be fixed with last p-u 1.5.1. I have tested it locally on a cygwin need to do more tests on a real unix .

          Rahul Thakur added a comment -

          So basically, as Jan Lisse noted, this should be ideally fixed in Maven-SCM

          Olivier Lamy added a comment -

          Just tested on a solaris machine and doesn't work

          2008-06-12 19:56:57,912 [pool-2-thread-1] INFO  org.apache.continuum.scm.manager.Slf4jScmLogger  - Executing: /bin/sh -c cd /local/continuum/continuum-work/working-directory && svn --username test --password ***** --non-interactive checkout http://57.200.1.171:7770/Accommons/olamy/trunk/my-app 132
          2008-06-12 19:56:57,913 [pool-2-thread-1] INFO  org.apache.continuum.scm.manager.Slf4jScmLogger  - Working directory: /local/continuum/continuum-work/working-directory
          2008-06-12 19:56:58,394 [pool-2-thread-1] WARN  action#checkout-project  - Error while checking out the code for project: 'Maven Quick Start Archetype', id: '132' to '/local/continuum/continuum-work/working-directory/132'.
          2008-06-12 19:56:58,394 [pool-2-thread-1] WARN  action#checkout-project  - Command output: svn: missing argument: --password
          Type 'svn help' for usage.
          /bin/sh: password: not found
          
          Olivier Lamy added a comment -

          Upgrade to last p-u fix the issue (tested on solaris env)


            People

            • Assignee:
              Olivier Lamy
              Reporter:
              Jan Lisse
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: