Continuum
  1. Continuum
  2. CONTINUUM-1322

Attempt to store value with more than 256 chars

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1-beta-1
    • Fix Version/s: 1.2
    • Component/s: None
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      Using latest snapshot (continuum-20070621.010000.war) I get this exception causing the project build not processed at all – red X on the project page, no build statistics to be found.

      690292 [Thread-2] ERROR org.codehaus.plexus.taskqueue.execution.TaskQueueExecutor:build-project - Error executing task
      edu.emory.mathcs.backport.java.util.concurrent.ExecutionException: javax.jdo.JDOFatalUserException: Attempt to store value "/soseco/dev/tahoe/applications/rcp/rcpmanager/src/main/java/biz/wss/rcp/rcpmanager/core/bundle/ManagerPartDelegateConfig.java (from /soseco/dev/tahoe/applications/rcp/rcpmanager/src/main/java/biz/wss/rcp/rcpmanager/parts/ManagerPartDelegateConfig.java:12912)" in column ""NAME"" that has maximum length of 256. Please correct your data!
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.getResult(FutureTask.java:299)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.get(FutureTask.java:128)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.waitForTask(ThreadedTaskQueueExecutor.java:165)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.run(ThreadedTaskQueueExecutor.java:127)
      Caused by: javax.jdo.JDOFatalUserException: Attempt to store value "/soseco/dev/tahoe/applications/rcp/rcpmanager/src/main/java/biz/wss/rcp/rcpmanager/core/bundle/ManagerPartDelegateConfig.java (from /soseco/dev/tahoe/applications/rcp/rcpmanager/src/main/java/biz/wss/rcp/rcpmanager/parts/ManagerPartDelegateConfig.java:12912)" in column ""NAME"" that has maximum length of 256. Please correct your data!
      at org.jpox.store.rdbms.mapping.CharRDBMSMapping.setString(CharRDBMSMapping.java:214)
      at org.jpox.store.mapping.SingleFieldMapping.setString(SingleFieldMapping.java:203)
      at org.jpox.store.rdbms.fieldmanager.ParameterSetter.storeStringField(ParameterSetter.java:122)
      at org.jpox.state.StateManagerImpl.providedStringField(StateManagerImpl.java:2757)
      at org.apache.maven.continuum.model.scm.ChangeFile.jdoProvideField(ChangeFile.java)
      at org.apache.maven.continuum.model.scm.ChangeFile.jdoProvideFields(ChangeFile.java)
      at org.jpox.state.StateManagerImpl.provideFields(StateManagerImpl.java:3115)
      at org.jpox.store.rdbms.request.InsertRequest.execute(InsertRequest.java:252)
      at org.jpox.store.rdbms.table.ClassTable.insert(ClassTable.java:2519)
      at org.jpox.store.StoreManager.insert(StoreManager.java:920)
      at org.jpox.state.StateManagerImpl.internalMakePersistent(StateManagerImpl.java:3667)
      at org.jpox.state.StateManagerImpl.makePersistent(StateManagerImpl.java:3646)
      at org.jpox.AbstractPersistenceManager.internalMakePersistent(AbstractPersistenceManager.java:1198)
      at org.jpox.AbstractPersistenceManager.makePersistentInternal(AbstractPersistenceManager.java:1243)
      at org.jpox.store.rdbms.scostore.FKListStore.validateElementForWriting(FKListStore.java:1231)
      at org.jpox.store.rdbms.scostore.FKListStore.internalAdd(FKListStore.java:772)
      at org.jpox.store.rdbms.scostore.AbstractListStore.addAll(AbstractListStore.java:386)
      at org.jpox.store.mapping.CollectionMapping.postInsert(CollectionMapping.java:209)
      at org.jpox.store.rdbms.request.InsertRequest.execute(InsertRequest.java:464)
      at org.jpox.store.rdbms.table.ClassTable.insert(ClassTable.java:2519)
      at org.jpox.store.StoreManager.insert(StoreManager.java:920)
      at org.jpox.state.StateManagerImpl.internalMakePersistent(StateManagerImpl.java:3667)
      at org.jpox.state.StateManagerImpl.makePersistent(StateManagerImpl.java:3646)
      at org.jpox.AbstractPersistenceManager.internalMakePersistent(AbstractPersistenceManager.java:1198)
      at org.jpox.AbstractPersistenceManager.makePersistentInternal(AbstractPersistenceManager.java:1243)
      at org.jpox.store.rdbms.scostore.FKListStore.validateElementForWriting(FKListStore.java:1231)
      at org.jpox.store.rdbms.scostore.FKListStore.internalAdd(FKListStore.java:772)
      at org.jpox.store.rdbms.scostore.AbstractListStore.addAll(AbstractListStore.java:386)
      at org.jpox.store.mapping.CollectionMapping.postInsert(CollectionMapping.java:209)
      at org.jpox.store.rdbms.request.InsertRequest.execute(InsertRequest.java:464)
      at org.jpox.store.rdbms.table.ClassTable.insert(ClassTable.java:2519)
      at org.jpox.store.StoreManager.insert(StoreManager.java:920)
      at org.jpox.state.StateManagerImpl.internalMakePersistent(StateManagerImpl.java:3667)
      at org.jpox.state.StateManagerImpl.makePersistent(StateManagerImpl.java:3646)
      at org.jpox.AbstractPersistenceManager.internalMakePersistent(AbstractPersistenceManager.java:1198)
      at org.jpox.AbstractPersistenceManager.makePersistentInternal(AbstractPersistenceManager.java:1243)
      at org.jpox.store.mapping.PersistenceCapableMapping.setObject(PersistenceCapableMapping.java:450)
      at org.jpox.store.rdbms.fieldmanager.ParameterSetter.storeObjectField(ParameterSetter.java:144)
      at org.jpox.state.StateManagerImpl.providedObjectField(StateManagerImpl.java:2771)
      at org.apache.maven.continuum.model.project.BuildResult.jdoProvideField(BuildResult.java)
      at org.apache.maven.continuum.model.project.BuildResult.jdoProvideFields(BuildResult.java)
      at org.jpox.state.StateManagerImpl.provideFields(StateManagerImpl.java:3115)
      at org.jpox.store.rdbms.request.InsertRequest.execute(InsertRequest.java:252)
      at org.jpox.store.rdbms.table.ClassTable.insert(ClassTable.java:2519)
      at org.jpox.store.StoreManager.insert(StoreManager.java:920)
      at org.jpox.state.StateManagerImpl.internalMakePersistent(StateManagerImpl.java:3667)
      at org.jpox.state.StateManagerImpl.makePersistent(StateManagerImpl.java:3646)
      at org.jpox.AbstractPersistenceManager.internalMakePersistent(AbstractPersistenceManager.java:1198)
      at org.jpox.AbstractPersistenceManager.makePersistent(AbstractPersistenceManager.java:1261)
      at org.codehaus.plexus.jdo.PlexusJdoUtils.makePersistent(PlexusJdoUtils.java:175)
      at org.apache.maven.continuum.store.JdoContinuumStore.makePersistent(JdoContinuumStore.java:717)
      at org.apache.maven.continuum.store.JdoContinuumStore.addBuildResult(JdoContinuumStore.java:436)
      at org.apache.maven.continuum.buildcontroller.DefaultBuildController.makeAndStoreBuildResult(DefaultBuildController.java:678)
      at org.apache.maven.continuum.buildcontroller.DefaultBuildController.updateBuildResult(DefaultBuildController.java:230)
      at org.apache.maven.continuum.buildcontroller.DefaultBuildController.performAction(DefaultBuildController.java:444)
      at org.apache.maven.continuum.buildcontroller.DefaultBuildController.build(DefaultBuildController.java:145)
      at org.apache.maven.continuum.buildcontroller.BuildProjectTaskExecutor.executeTask(BuildProjectTaskExecutor.java:50)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
      at java.lang.Thread.run(Thread.java:595)

        Issue Links

          Activity

          Olivier Lamy added a comment -

          related to CONTINUUM-1338 (I hope 512 lenght will be enough )

          Pavel Halas added a comment -

          I cannot verify the the bug is fixed. On the latest version continuum-20071002.110002.war the issue remains.

          4569627 [Thread-3] ERROR org.codehaus.plexus.taskqueue.execution.TaskQueueExecutor:build-project  - Error executing task
          edu.emory.mathcs.backport.java.util.concurrent.ExecutionException: javax.jdo.JDOFatalUserException: Attempt to store value "/soseco/dev/nirvana/java/programs/pricing/src/main/java/biz/wss/rcp/pricing/entity/quotes/ComparableMarketQuote.java (from /soseco/7.2/7.2.0/dev/nirvana/java/programs/pricing/src/main/java/biz/wss/rcp/pricing/entity/quotes/ComparableMarketQuote.java:21428)" in column ""NAME"" that has maximum length of 255. Please correct your data!
                  at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.getResult(FutureTask.java:299)
                  at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.get(FutureTask.java:128)
                  at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.waitForTask(ThreadedTaskQueueExecutor.java:165)
                  at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.run(ThreadedTaskQueueExecutor.java:127)
          Caused by: javax.jdo.JDOFatalUserException: Attempt to store value "/soseco/dev/nirvana/java/programs/pricing/src/main/java/biz/wss/rcp/pricing/entity/quotes/ComparableMarketQuote.java (from /soseco/7.2/7.2.0/dev/nirvana/java/programs/pricing/src/main/java/biz/wss/rcp/pricing/entity/quotes/ComparableMarketQuote.java:21428)" in column ""NAME"" that has maximum length of 255. Please correct your data!
                  at org.jpox.store.rdbms.mapping.CharRDBMSMapping.setString(CharRDBMSMapping.java:214)
                  at org.jpox.store.mapping.SingleFieldMapping.setString(SingleFieldMapping.java:203)
                  at org.jpox.store.rdbms.fieldmanager.ParameterSetter.storeStringField(ParameterSetter.java:122)
                  at org.jpox.state.StateManagerImpl.providedStringField(StateManagerImpl.java:2757)
                  at org.apache.maven.continuum.model.scm.ChangeFile.jdoProvideField(ChangeFile.java)
                  at org.apache.maven.continuum.model.scm.ChangeFile.jdoProvideFields(ChangeFile.java)
                  at org.jpox.state.StateManagerImpl.provideFields(StateManagerImpl.java:3115)
                  at org.jpox.store.rdbms.request.InsertRequest.execute(InsertRequest.java:252)
                  at org.jpox.store.rdbms.table.ClassTable.insert(ClassTable.java:2519)
                  at org.jpox.store.StoreManager.insert(StoreManager.java:920)
                  at org.jpox.state.StateManagerImpl.internalMakePersistent(StateManagerImpl.java:3667)
                  at org.jpox.state.StateManagerImpl.makePersistent(StateManagerImpl.java:3646)
                  at org.jpox.AbstractPersistenceManager.internalMakePersistent(AbstractPersistenceManager.java:1198)
                  at org.jpox.AbstractPersistenceManager.makePersistentInternal(AbstractPersistenceManager.java:1243)
          
          Emmanuel Venisse added a comment -

          I think the patch is included in this war. How do you test it? with a fresh database or an old one?

          Pavel Halas added a comment -

          I did not test it any special way, I've just created my projects in the brand new database...

          Jan Gr added a comment -

          we use continuum version 1.1 and the problem is not fixed

          see screenshot

          Ryan C. Payne added a comment -

          I am using Continuum-1.1 and am receiving a similar error, however the line number in the DefaultBuildController.java class (Line 715) is different from the one listed above (Line 678).

          My stack trace:
          859471276 [Thread-6] ERROR org.codehaus.plexus.taskqueue.execution.TaskQueueExecutor:build-project - Error executing task
          edu.emory.mathcs.backport.java.util.concurrent.ExecutionException: javax.jdo.JDOFatalUserException: Attempt to store value "/dev/xxxxx/trunk/xxxxx/applications/xxxxxxx/src/main/java/com/xxxxxxx/xxxxxxx/util/comparators/CustomerApplicationNameComparator.java (from /dev/xxxxx/trunk/xxxxx/applications/xxxxxxx/src/main/java/com/xxxxxxx/xxxxxxx/util/comparators/ApplicationNameComparator.java:1202)" in column ""NAME"" that has maximum length of 255. Please correct your data!
          at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.getResult(FutureTask.java:299)
          at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.get(FutureTask.java:128)
          at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.waitForTask(ThreadedTaskQueueExecutor.java:165)
          at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable.run(ThreadedTaskQueueExecutor.java:127)
          Caused by: javax.jdo.JDOFatalUserException: Attempt to store value "/dev/xxxxx/trunk/xxxxx/applications/xxxxxxx/src/main/java/com/xxxxxxx/xxxxxxx/util/comparators/CustomerApplicationNameComparator.java (from /dev/xxxxx/trunk/xxxxx/applications/xxxxxxx/src/main/java/com/xxxxxxx/xxxxxxx/util/comparators/ApplicationNameComparator.java:1202)" in column ""NAME"" that has maximum length of 255. Please correct your data!
          at org.jpox.store.rdbms.mapping.CharRDBMSMapping.setString(CharRDBMSMapping.java:214)
          at org.jpox.store.mapping.SingleFieldMapping.setString(SingleFieldMapping.java:203)
          at org.jpox.store.rdbms.fieldmanager.ParameterSetter.storeStringField(ParameterSetter.java:122)
          at org.jpox.state.StateManagerImpl.providedStringField(StateManagerImpl.java:2757)
          at org.apache.maven.continuum.model.scm.ChangeFile.jdoProvideField(ChangeFile.java)
          at org.apache.maven.continuum.model.scm.ChangeFile.jdoProvideFields(ChangeFile.java)
          at org.jpox.state.StateManagerImpl.provideFields(StateManagerImpl.java:3115)
          at org.jpox.store.rdbms.request.InsertRequest.execute(InsertRequest.java:252)
          at org.jpox.store.rdbms.table.ClassTable.insert(ClassTable.java:2519)
          at org.jpox.store.StoreManager.insert(StoreManager.java:920)
          at org.jpox.state.StateManagerImpl.internalMakePersistent(StateManagerImpl.java:3667)
          at org.jpox.state.StateManagerImpl.makePersistent(StateManagerImpl.java:3646)
          at org.jpox.AbstractPersistenceManager.internalMakePersistent(AbstractPersistenceManager.java:1198)
          at org.jpox.AbstractPersistenceManager.makePersistentInternal(AbstractPersistenceManager.java:1243)
          at org.jpox.store.rdbms.scostore.FKListStore.validateElementForWriting(FKListStore.java:1231)
          at org.jpox.store.rdbms.scostore.FKListStore.internalAdd(FKListStore.java:772)
          at org.jpox.store.rdbms.scostore.AbstractListStore.addAll(AbstractListStore.java:386)
          at org.jpox.store.mapping.CollectionMapping.postInsert(CollectionMapping.java:209)
          at org.jpox.store.rdbms.request.InsertRequest.execute(InsertRequest.java:464)
          at org.jpox.store.rdbms.table.ClassTable.insert(ClassTable.java:2519)
          at org.jpox.store.StoreManager.insert(StoreManager.java:920)
          at org.jpox.state.StateManagerImpl.internalMakePersistent(StateManagerImpl.java:3667)
          at org.jpox.state.StateManagerImpl.makePersistent(StateManagerImpl.java:3646)
          at org.jpox.AbstractPersistenceManager.internalMakePersistent(AbstractPersistenceManager.java:1198)
          at org.jpox.AbstractPersistenceManager.makePersistentInternal(AbstractPersistenceManager.java:1243)
          at org.jpox.store.rdbms.scostore.FKListStore.validateElementForWriting(FKListStore.java:1231)
          at org.jpox.store.rdbms.scostore.FKListStore.internalAdd(FKListStore.java:772)
          at org.jpox.store.rdbms.scostore.AbstractListStore.addAll(AbstractListStore.java:386)
          at org.jpox.store.mapping.CollectionMapping.postInsert(CollectionMapping.java:209)
          at org.jpox.store.rdbms.request.InsertRequest.execute(InsertRequest.java:464)
          at org.jpox.store.rdbms.table.ClassTable.insert(ClassTable.java:2519)
          at org.jpox.store.StoreManager.insert(StoreManager.java:920)
          at org.jpox.state.StateManagerImpl.internalMakePersistent(StateManagerImpl.java:3667)
          at org.jpox.state.StateManagerImpl.makePersistent(StateManagerImpl.java:3646)
          at org.jpox.AbstractPersistenceManager.internalMakePersistent(AbstractPersistenceManager.java:1198)
          at org.jpox.AbstractPersistenceManager.makePersistentInternal(AbstractPersistenceManager.java:1243)
          at org.jpox.store.mapping.PersistenceCapableMapping.setObject(PersistenceCapableMapping.java:450)
          at org.jpox.store.rdbms.fieldmanager.ParameterSetter.storeObjectField(ParameterSetter.java:144)
          at org.jpox.state.StateManagerImpl.providedObjectField(StateManagerImpl.java:2771)
          at org.apache.maven.continuum.model.project.BuildResult.jdoProvideField(BuildResult.java)
          at org.apache.maven.continuum.model.project.BuildResult.jdoProvideFields(BuildResult.java)
          at org.jpox.state.StateManagerImpl.provideFields(StateManagerImpl.java:3115)
          at org.jpox.store.rdbms.request.InsertRequest.execute(InsertRequest.java:252)
          at org.jpox.store.rdbms.table.ClassTable.insert(ClassTable.java:2519)
          at org.jpox.store.StoreManager.insert(StoreManager.java:920)
          at org.jpox.state.StateManagerImpl.internalMakePersistent(StateManagerImpl.java:3667)
          at org.jpox.state.StateManagerImpl.makePersistent(StateManagerImpl.java:3646)
          at org.jpox.AbstractPersistenceManager.internalMakePersistent(AbstractPersistenceManager.java:1198)
          at org.jpox.AbstractPersistenceManager.makePersistent(AbstractPersistenceManager.java:1261)
          at org.codehaus.plexus.jdo.PlexusJdoUtils.makePersistent(PlexusJdoUtils.java:175)
          at org.apache.maven.continuum.store.JdoContinuumStore.makePersistent(JdoContinuumStore.java:1000)
          at org.apache.maven.continuum.store.JdoContinuumStore.addBuildResult(JdoContinuumStore.java:438)
          at org.apache.maven.continuum.buildcontroller.DefaultBuildController.makeAndStoreBuildResult(DefaultBuildController.java:715)
          at org.apache.maven.continuum.buildcontroller.DefaultBuildController.updateBuildResult(DefaultBuildController.java:232)
          at org.apache.maven.continuum.buildcontroller.DefaultBuildController.performAction(DefaultBuildController.java:446)
          at org.apache.maven.continuum.buildcontroller.DefaultBuildController.build(DefaultBuildController.java:147)
          at org.apache.maven.continuum.buildcontroller.BuildProjectTaskExecutor.executeTask(BuildProjectTaskExecutor.java:50)
          at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
          at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
          at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
          at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:665)
          at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:690)
          at java.lang.Thread.run(Thread.java:613)

          Olivier Lamy added a comment -

          fix with CONTINUUM-1688 (max size is now 1024)


            People

            • Assignee:
              Olivier Lamy
              Reporter:
              Pavel Halas
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: