Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: 1.3.3 (Beta)
    • Component/s: Core system, Database
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      I don't really want/need this - but after deleting it, it keeps coming back

      1. CONTINUUM-1130.patch
        6 kB
        Jose Morales Martinez

        Activity

        George Gastaldi added a comment -

        It is still a problem in version 1.1-beta-3.

        Wendy Smoak added a comment -

        In 1.1 Final, attempting to delete the Default project group results in:

        Error Occurred
        javax.jdo.JDOUserException: One or more instances could not be deleted NestedThrowables: javax.jdo.JDODataStoreException: Delete request failed: DELETE FROM BUILDDEFINITION WHERE ID = ? NestedThrowables: SQL Exception: DELETE on table 'BUILDDEFINITION' caused a violation of foreign key constraint 'BUILDDEFINITCE_FK2' for key (3). The statement has been rolled back.

        Show/hide Stack Trace

                javax.jdo.JDOUserException: One or more instances could not be deleted
        	at org.jpox.AbstractPersistenceManager.deletePersistentAll(AbstractPersistenceManager.java:1525)
        	at org.jpox.store.rdbms.scostore.ElementContainerStore.clear(ElementContainerStore.java:662)
        ...
        NestedThrowablesStackTrace:
        javax.jdo.JDODataStoreException: Delete request failed: DELETE FROM BUILDDEFINITION WHERE ID = ?
        	at org.jpox.store.rdbms.request.DeleteRequest.execute(DeleteRequest.java:288)
        	at org.jpox.store.rdbms.table.ClassTable.delete(ClassTable.java:2611)
        	at org.jpox.store.StoreManager.delete(StoreManager.java:981)
        ...
        NestedThrowablesStackTrace:
        ERROR 23503: DELETE on table 'BUILDDEFINITION' caused a violation of foreign key constraint 'BUILDDEFINITCE_FK2' for key (3).  The statement has been rolled back.
        	at org.apache.derby.iapi.error.StandardException.newException(Unknown Source)
        	at org.apache.derby.impl.sql.execute.ReferencedKeyRIChecker.doCheck(Unknown Source)
        	at org.apache.derby.impl.sql.execute.RISetChecker.doPKCheck(Unknown Source)
        ...
        
        Rahul Thakur added a comment -

        Ok, I could be wrong but IIRC the idea of having a default Project Group was that no Projects would live outside a ProjectGroup.

        Should we allow renaming the default ProjectGroup instead of deleting it?

        Brett Porter added a comment -

        I would say only allow deleting it if it is empty, and there are no other groups. That way adding a project can always require addiion to an existing project group

        Jose Morales Martinez added a comment -

        The problem is not because it is the default project group, It's due to the fact project group contains a template definition. I obtain the same error by creating new project group and assign a template definition.

        I got that Continuum can eliminate this type of projectgroup, but when they have problems with the generation of projects and Ant Console. Only need create a not null restriction about group project.

        You believe that it would be working on this improvement, or just perform a single validation, so as not to allow the removal of the default project group?

        Jose Morales Martinez added a comment -

        This patch allow delete default project group and project groups which have associated build templates. It also validates that when we add an Ant or Shell project, it must be in a project group .

        Note: When we restart Continuum application, it creates the default project, I am working for to do that only the first time it create default project. Anyway, someone has a suggestion?

        Emmanuel Venisse added a comment -

        This patch delete the Default Project Group but we have an exception in logs.

        Emmanuel Venisse added a comment -

        Fixed in rev.760328
        Now it is possible to remove the default project group without exception in logs. When a group is created the build definition template is cloned so th exception won't appear in the future.


          People

          • Assignee:
            Emmanuel Venisse
            Reporter:
            Brett Porter
          • Votes:
            5 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: