Ah, OK, I thought maybe the .castor.cdr was sufficient, but I agree that updating the CDR to also look in a specially-named subdirectory would be even better. This means, however, that the constant that names the subdirectory name should be owned by Castor-XML and not by Castor-XML-srcgen. It also means that we don't want people to have the ability to configure the name of this directory, so we should choose a name that people are unlikely to use for their own class files.
The name "descriptors" might be Good Enough. A longer package name such as castordescriptors seems unnecessary – but much less likely to confict with a directory that someone wants to use for their own code package.
Although finally, IMO, I think that generated code should usually be put into its own package and a separate package from code that is not generated, making code maintenance easier. Thus, as a general rule and best practice, I would recommend that anyone using the source generator choose a package that they are not using for other code for their generated code.