castor
  1. castor
  2. CASTOR-1944

ArrayIndexOutOfBoundsException with BaseFactory

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.1
    • Fix Version/s: 1.1.1
    • Component/s: XML code generator
    • Labels:
      None
    • Number of attachments :
      1

      Description

      Submitted on behalf of Richard Perrott:

      I saw an ArrayIndexOutOfBoundsException for org.exolab.castor.builder.BaseFactory in Castor 1.0.5 and now for Castor 1.1, for XML class building, it obviously had not been fixed in Castor 1.1 and was a time critical issue for me, so here is the fix ported to Castor 1.1, to help other people.

      See line 104 of the patched source file for details.

      Regards,

      Richard Perrott

        Issue Links

          Activity

          Werner Guttmann added a comment -

          This is a duplicate of CASTOR-1905.


            People

            • Assignee:
              Werner Guttmann
              Reporter:
              Keith Visco
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: