Details

    • Type: Sub-task Sub-task
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.1 M3
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      5
    1. castor-1832-ctf.diff
      2 kB
      Edward Kuns
    2. castor-1832-diff1.diff
      37 kB
      Edward Kuns
    3. castor-1832-mapping.diff
      7 kB
      Edward Kuns
    4. castor-1832-xmldiff.diff
      13 kB
      Edward Kuns
    5. castor-srcgen-tests-patch.diff
      77 kB
      Edward Kuns

      Activity

      Edward Kuns added a comment -

      Deleted unnecessary class files under MasterTestSuite/introspection

      Edward Kuns added a comment -

      Deleted unnecessary class files under MasterTestSuite/mapping.

      Edward Kuns added a comment -

      XML output comparisons now deliberately suppressed in the following tests:

      src/tests/xml/MasterTestSuite/mapping/ByteArrays/TestDescriptor.xml
      src/tests/xml/MasterTestSuite/mapping/GSC_Regression/TestDescriptor.xml
      src/tests/xml/MasterTestSuite/mapping/Inheritance_Regression1/TestDescriptor.xml

      XML output comparison was previously accidentally suppressed in those tests (and others).

      Edward Kuns added a comment -

      Attaching diff to fix/improve namespace handling of xmldiff.

      Edward Kuns added a comment -

      Attaching patch for CTF to:

      1) Enable XML output comparison where previously it has not been done, and
      2) Provide a way to disable that comparison by supplying an empty GoldFile element.

      Now, A gold file need only be supplied in the TestDescriptor.xml if it is different than the input file or if no input file is given because an object is used to construct the initial test object.

      Edward Kuns added a comment -

      Attaching patch of corrections to srcgen MasterTestSuite tests so that they pass XML comparisons that were not done before.

      Mostly, this is adding correct xmlns declarations to the root elements on the input files.

      Edward Kuns added a comment -

      All changes delivered.


        People

        • Assignee:
          Edward Kuns
          Reporter:
          Edward Kuns
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: