Details

    • Type: Sub-task Sub-task
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0.3
    • Fix Version/s: 1.0.4
    • Component/s: General
    • Labels:
      None
    • Number of attachments :
      1

      Description

      Building the javadoc generated hundreds of complaints and several exceptions. I've cleaned that up so now there are 9 warnings and no exceptions. The exceptions were caused by a bug in the JavaDoc tool:

      http://bugs.sun.com/bugdatabase/view_bug.do;jsessionid=c3e72899d92ad3af6662f44481ef:WuuT?bug_id=5082928

      It sometimes choked when it saw < followed by "a" if it wasn't a link.

      I touched only Javadoc, no code. Where the correct value was not obvious, I left it alone. I didn't go hunting for Eclipse warnings, but targeted the complaints from the javadoc tool itself during build. (Thus limiting the scope of the work enormously!) Missing parameters weren't added.

        Activity

        Edward Kuns made changes -
        Field Original Value New Value
        Priority Major [ 3 ] Minor [ 4 ]
        Affects Version/s 1.0.3 [ 12762 ]
        Fix Version/s 1.0.4 [ 12888 ]
        Description Building the javadoc generated hundreds of complaints and several exceptions. I've cleaned that up so now there are 9 warnings and no exceptions. The exceptions were caused by a bug in the JavaDoc tool:

        http://bugs.sun.com/bugdatabase/view_bug.do;jsessionid=c3e72899d92ad3af6662f44481ef:WuuT?bug_id=5082928

        It sometimes choked when it saw < followed by "a" if it wasn't a link.

        I touched only Javadoc, no code. Where the correct value was not obvious, I left it alone. I didn't go hunting for Eclipse warnings, but targeted the complaints from the javadoc tool itself during build. (Thus limiting the scope of the work enormously!) Missing parameters weren't added.

        Component/s General [ 11502 ]
        Edward Kuns added a comment -

        Patch attached.

        Edward Kuns made changes -
        Attachment javadoc.cleanup.diff [ 22928 ]
        Werner Guttmann made changes -
        Assignee Edward Kuns [ edward.kuns@rockwellfirstpoint.com ] Werner Guttmann [ wguttmn ]
        Werner Guttmann added a comment -

        Edward, thank you for this patch. I just applied it against SVN, it unfortunately there's a few files where it is not possible to apply that patch, with the focus being on SVN headers or similar. As far as I can tell, we are talking about 10 odd files where e.g. a @see FieldHandler could not be changed to @see full.package.name.FieldHandler .. .

        Werner Guttmann made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Werner Guttmann made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Werner Guttmann
            Reporter:
            Edward Kuns
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: