castor
  1. castor
  2. CASTOR-1434

Improve test coverage for 'auto-store' attribute

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: 1.0.2
    • Component/s: JDO tests
    • Labels:
      None
    • Number of attachments :
      5

      Description

      The Clover reports (as part of the Maven build) indicate that the Castor JDO CTF suite apparently lacks test cases that make use of the auto-store property.

      1. patch.c1434.20060523.txt
        13 kB
        Werner Guttmann
      2. patch.c1434.20060528.txt
        24 kB
        Werner Guttmann
      3. patch.c1434.20060529.txt
        41 kB
        Werner Guttmann
      4. patch.c1434.20060612.txt
        49 kB
        Werner Guttmann
      5. patch.c1434.20060613.txt
        49 kB
        Werner Guttmann

        Activity

        Werner Guttmann added a comment -

        Initial patch, testing some simple scenarios related to the use of auto-sore="true" for simple 1:1 relations (during create and commit (short transactions only).

        Werner Guttmann added a comment -

        Moved test case into Castor JDO CTF suite (ctf.jdo.tc7x.TestAutostore), and changed source code to follow CTF conventions.

        Werner Guttmann added a comment -

        Correct patch ..

        Werner Guttmann added a comment -

        Thinking about adding some test cases for other (not tested) methods on the Database interface ...

        Werner Guttmann added a comment -

        Updated patch, incl. new tests for 1:M relations, and at the same time fixing some minor typos in the original test case. Please note that the new tests work for mySQL only (as I have not updated tests.xml and the non-mySQL DDL scripts yet).

        Werner Guttmann added a comment -

        Same patch again, though this time with updates to src/test/resources/tests.xml and the DDL scripts. I actually thinking about committing this is as .. sort of hoping that somebody else might fill in a few holes ... .

        Werner Guttmann added a comment -

        Updated (and hopefully final) patch. The code clearly shows that (apart from cascading deletes) auto-storing works as intended for 1:1 and 1:M relations.


          People

          • Assignee:
            Werner Guttmann
            Reporter:
            Werner Guttmann
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 30 minutes
              30m