There are some things in the archetypes that could be improved:
- Remove finaleName (replace with context configuration)
- The finaleName configuration is very often misunderstood by Maven users. It only changes the name of the file created in target/. The actual artifact in the local or remote repository isn't changed. So, if this settings isn't required I'd like it to be removed so that people are not confused.
- The directory names of the modules in the functional-tests archetype should be named according to their artifactId
- Maven best-practice
- Cargo plugin configuration should be moved to pluginManagement
- This will enable executing the cargo plugin from the command line with the same configuration (not only as bound to the lifecycle)